WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
Archives widget, search not working (6 posts)

  1. Gugols
    Member
    Posted 10 months ago #

    Hi, I am using Polylang Version 1.1.6 with Magazon theme and got some issues:

    1) Archives widget not working. Instead of loading:

    http://example.com/2013/10/ <-- Which works
    it loads:
    http://example.com/language/lv/2013/10/ <-- Results in 404 error.

    The same for search. Instead of:

    http://example.com/?s=keyword1
    it loads
    http://exammple.com/homepage/?s=keyword1

    The search snippet:

    <form id="nav-searchform" method="get" action="<?php echo home_url(); ?>">
                                            <div class="iw">
                                            	<input type="submit" value="Search" class="search-submit">
                                            	<input type="text" name="s" value="" placeholder="<?php  echo esc_attr(__('SEARCH...','magazon')); ?>" class="s closed">
    
                                            </div>
                                        </form>

    http://wordpress.org/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 10 months ago #

    http://example.com/language/lv/2013/10/ <-- Results in 404 error.

    Have you some content written in October 2013 in Latvian?

    Is your search snippet in file called searchform.php?

  3. Gugols
    Member
    Posted 10 months ago #

    Have you some content written in October 2013 in Latvian?

    Yes, I have and it loads successfully if "language/lv/" part is removed.

    Is your search snippet in file called searchform.php?

    No, it's located in header.php.

  4. Chouby
    Member
    Plugin Author

    Posted 10 months ago #

    Is latvian your default language? Did you choose to hide the language code for the default language?

    For the search form, your theme is doing things wrong. But there should be workaround. One of it is to choose to redirect the homepage to the language page in Polylang settings.

  5. Gugols
    Member
    Posted 10 months ago #

    Is latvian your default language? Did you choose to hide the language code for the default language?

    Yes, it is. I didn't but now I did and at least the archives work for default language(since language/lv part got removed). For others(ENG/RUS) it still fails. Any suggestions?

    For the search form, your theme is doing things wrong. But there should be workaround. One of it is to choose to redirect the homepage to the language page in Polylang settings.

    Thanks, this worked.

  6. Chouby
    Member
    Plugin Author

    Posted 10 months ago #

    Could you de-activate all your plugins except Polylang, switch to a default theme (twenty twelve), and press the save changes button in readings->permalinks?

    If it does work, then switch back to your theme and activate other plugins one by one to detect which one is conflicting.

Reply

You must log in to post.

About this Plugin

About this Topic