WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Archives showing "0"? (13 posts)

  1. elfreakz
    Member
    Posted 6 years ago #

    http://img399.imageshack.us/img399/5295/archievesdd2.jpg

    refer to the image above, why i have 0 at the last archives? when i open it, it say NOT FOUND on my blog?

  2. iridiax
    Member
    Posted 6 years ago #

    It may be a permalinks/.htaccess problem... Do any of your archive links work? Or it's a link to something else, what should be there?

  3. elfreakz
    Member
    Posted 6 years ago #

    all other month and year work like normally.

    actually, i edit all my post date.. when update all the month and year, i get "0" as the last archives. i already check all my post, and they are all sort my correct month and year now. but why is that 0 appear there?

  4. elfreakz
    Member
    Posted 6 years ago #

    0 = http://www..com/2008/07/

    April 2008 = http://www..com/2008/04/

    May 2008 = http://www..com/2008/05/

    June 2008 = http://www..com/2008/06/

    ok i have july 2008 post, so the link will be http://www..com/2008/07/

    as you can see now... i have http://www..com/2008/07/ for july 2008, why do i have the same link for july but name "0" ?

  5. iridiax
    Member
    Posted 6 years ago #

    What is the code used to generate these archives? You don't just have a 0, the order is also really odd.

  6. elfreakz
    Member
    Posted 6 years ago #

    you mean the permalink?

    /%year%/%monthnum%/%day%/%postname%/

    try to go the blog http://www.thecatzine.com/

    scroll down you see the "0" in archives...

  7. elfreakz
    Member
    Posted 6 years ago #

    i already have July 2008 archives.. when u click "0", it will link to July 2008. Weird...

  8. iridiax
    Member
    Posted 6 years ago #

    No, I mean the code in your sidebar.php. It looks like the 0 and the archives are either two separate bits of code or something strange is being done to the current month's archives. Are you using any plugins that would affect archives?

  9. elfreakz
    Member
    Posted 6 years ago #

    disable all plugins = still the "0" appear.

    archives using widget..

    i get this when i actually modify all my post date. but i do not know from where and how that "0" appears.

  10. Terry
    Member
    Posted 6 years ago #

    I had the exact same problem and here is the fix:

    http://wordpress.org/support/topic/147101

  11. elfreakz
    Member
    Posted 6 years ago #

    i dont really get the guide at http://wordpress.org/support/topic/147101

    you mention:
    By doing what was suggested in here, I was able to find a post that was time stamped with 0000-00-00 in the database. I changed it to a real date and now the "0" is now gone from my sidebar archive links. Thanks!

    which one should i edit?

  12. Terry
    Member
    Posted 6 years ago #

    elfreakz you have to go into phpadmin to work with the database

    In left column, click the wordpress database link
    Click on wp-posts link (left column)
    Click Browse (right column)
    Click on post_date (right column of screen)

    This will sort your posts by date, you'll see the top entry is date stamped with:

    0000-00-00 00:00:00

    Change the date by clicking the pencil to the left of the row, make the date change, scroll to the bottom and click the "go" button to save.

    Watch: If you have drafts sitting in wordpress, they'll all be marked with that timestamp. I think what happened with us is that when we upgraded wordpress at some point, the drafts that were sitting in the database at the time and then published later kept the 0000-00-00 00:00:00 timestamp instead of the date they were published (just from what I gathered reading here on the forum).

  13. elfreakz
    Member
    Posted 6 years ago #

    Thanks Terry :)

    Problem solve :) great guide :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags