WordPress.org

Ready to get started?Download WordPress

Forums

Archives - no posts show (12 posts)

  1. JAHS
    Member
    Posted 9 years ago #

    I did a search here and found other people had problems with their archives with giving an error or only showing a few posts. But I am having different problems with mine. When I click on either of the two months listed as archives on my blog, I just get the message:

    Sorry, no posts matched your criteria.

    And yet I know some posts should be there. The url it goes to is: h ttp://mydomain.com/date/2005/06/ . I was wondering if the problem was related to mod_rewrite, but links to individual posts work, so I don't know. Any ideas? Thanks

  2. Joshua Sigar
    Member
    Posted 9 years ago #

    I was wondering if the problem was related to mod_rewrite...

    Does it work fine with permalink feature disabled?

    What's precisely your permalink structure, btw?

  3. Sunny7L
    Member
    Posted 9 years ago #

    I had this problem last night and FINALLY realized that I was incorrectly linking to my categories, leaving out the category "slug." So, despite that the links accessed the particular categories index page the next/prev links were linking to non-existent pages (hope that's clear :)).

    So, try checking your template to make sure you're linking to the full (and correct) URI for the category.

  4. JAHS
    Member
    Posted 9 years ago #

    The following is my permalink structure:

    /%category%/%year%/%monthnum%/%day%/%post_id%/

    I haven't tried disabling the permalink feature, I have to check to see how you do that, it looks like it might be just a matter of clearing out the htaccess file.

    Sunny7L - what does that slug thing do anyway? Maybe that is my problem too. I don't put anything in there for that. The links to the categories work though. But, now that I think about it, when I had it set to show less posts on the main page, the 'Next Page' link, gives me the same message as above.

    Are we allowed to give out our urls here? And would that help?

  5. Joshua Sigar
    Member
    Posted 9 years ago #

    To disable permalink
    1. Go to Options->Permalinks
    2. Empty the text field for "Structure" and "Category Base"
    3. Click on "Update Permalink Structure"

    URL will always be helpful.

  6. JAHS
    Member
    Posted 9 years ago #

    I didn't have anything in 'Category Base' though, its not necessary though is it? WP wasn't able to update my htaccess file though, so that will have to be done manually. (At the time I am writing this the structure is still in there)

    I just tried adding a 'page' to the blog also, and I get the same error when I try clicking on that link too. It does seem like the slug thing could be related.

    Site is: http://thispalebluedot.com/

  7. Joshua Sigar
    Member
    Posted 9 years ago #

    so just get rid of that .htaccess file for now, and see what we get

  8. JAHS
    Member
    Posted 9 years ago #

    ok, without the htaccess file, everything else works now.

    So what was wrong with the way I had the structure set up that it would cause a problem like that?

  9. Joshua Sigar
    Member
    Posted 9 years ago #

    Okay, now repeat the step to enable permalink, see if you have better luck this time ;)

    Using the structure you had should be fine

  10. JAHS
    Member
    Posted 9 years ago #

    Unless I'm getting too sleepy and it just looks like it is working now but really isn't - why did just remaking the file and reloading make everything work?

  11. Joshua Sigar
    Member
    Posted 9 years ago #

    your guess is as good as mine :)

  12. JAHS
    Member
    Posted 9 years ago #

    Well, thanks for all your help! I don't think it would have ever occured to me to try that!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags