WordPress.org

Ready to get started?Download WordPress

Forums

Archive- trouble clicking on links in archive (4 posts)

  1. dinneenp
    Member
    Posted 5 years ago #

    HI,
    I'm using Monotone theme. In Archive ( http://patrick.dinneen.com/2009/ ) I can't click on an image to get to the page but if I click on the grey area around the image it works.

    Problem doesn't exist in Firefox, does in IE 8.

    Anyone able to help?
    Cheers,
    Pa.

  2. dinneenp
    Member
    Posted 5 years ago #

    here is the code in my archive-
    <?php get_header(); rewind_posts(); ?>
    <div class="archive">

    <ul id="filters">

  3. Filter by:
  4. <select name="archive-dropdown" onChange='document.location.href=this.options[this.selectedIndex].value;'>
    <option value=""><?php echo attribute_escape(__('Select Month')); ?></option>
    <?php wp_get_archives('type=monthly&format=option&show_post_count=1'); ?> </select>
  5. <?php wp_dropdown_categories('show_option_none=Select Category'); ?>

    <script type="text/javascript"><!--
    var dropdown = document.getElementById("cat");
    function onCatChange() {
    if ( dropdown.options[dropdown.selectedIndex].value > 0 ) {
    location.href = "<?php echo get_option('home');
    ?>/?cat="+dropdown.options[dropdown.selectedIndex].value;
    }
    }
    dropdown.onchange = onCatChange;
    --></script>

  6. <?php
    query_posts($query_string.'&posts_per_page=24');
    if (have_posts()) : ?>

    <?php $post = $posts[0]; // Hack. Set $post so that the_date() works. ?>
    <?php /* If this is a category archive */ if (is_category()) { ?>
    <h2>Archive for the ‘<?php single_cat_title(); ?>’ Category</h2>
    <?php /* If this is a tag archive */ } elseif( is_tag() ) { ?>
    <h2>Posts Tagged ‘<?php single_tag_title(); ?>’</h2>
    <?php /* If this is a daily archive */ } elseif (is_day()) { ?>
    <h2>Archive for <?php the_time('F jS, Y'); ?></h2>
    <?php /* If this is a monthly archive */ } elseif (is_month()) { ?>
    <h2>Archive for <?php the_time('F, Y'); ?></h2>
    <?php /* If this is a yearly archive */ } elseif (is_year()) { ?>
    <h2>Archive for <?php the_time('Y'); ?></h2>
    <?php /* If this is an author archive */ } elseif (is_author()) { ?>
    <h2>Author Archive</h2>
    <?php /* If this is a paged archive */ } elseif (isset($_GET['paged']) && !empty($_GET['paged'])) { ?>
    <h2>Blog Archives</h2>
    <?php } ?>

    <div class="nav">
    <div class="prev"><?php next_posts_link('« Older Entries') ?></div>
    <div class="next"><?php previous_posts_link('Newer Entries »') ?></div>
    </div>
    <ul class="thumbnails">
    <?php while (have_posts()) : the_post(); ?>

    <li id="post-<?php the_ID(); ?>">
    " title="Link to <?php the_title_attribute(); ?>"><?php the_thumbnail(); ?>

    <?php endwhile; ?>

    <div class="nav">
    <div class="prev"><?php next_posts_link('« Older Entries') ?></div>
    <div class="next"><?php previous_posts_link('Newer Entries »') ?></div>
    </div>

    <?php else : ?>

    <h2 class="center">Not Found</h2>
    <?php include (TEMPLATEPATH . '/searchform.php'); ?>

    <?php endif; ?>
    </div>

    <?php get_footer(); ?>

  • dinneenp
    Member
    Posted 5 years ago #

    can anyone please help????

  • jpdeboer
    Member
    Posted 5 years ago #

    Also same problem in IE7!

  • Topic Closed

    This topic has been closed to new replies.

    About this Topic

    Tags