WordPress.org

Ready to get started?Download WordPress

Forums

Archive Pages Not Found (15 posts)

  1. jpettit
    Member
    Posted 9 years ago #

    When i have a multiple page archive (for any archive, month, category, etc) if you choose "previous entries" i am getting a '404 Not Found' error. This is the link:
    ?php posts_nav_link('','','« Previous Entries') ?

    I am using WP 1.5-gamma 2005-02-08, with Kubrick 1.2.5.
    I also have Permalinks turned on. The page with the issue is: http://www.pixies.ca/wordpress/archives/category/wordpress/

    Thanks for your help.

  2. jpettit
    Member
    Posted 9 years ago #

    When i turn off Permalinks this problem goes away. Does anyone have any insight as to why this occurs when Permalinks are turned on. I am using:
    /archives/%year%/%monthnum%/%day%/%postname%/

    Thanks.

  3. jpettit
    Member
    Posted 9 years ago #

    oh... if a look at my site is required it's pixies.ca.
    Thanks.

  4. jpettit
    Member
    Posted 9 years ago #

    I was able to fix this by NOT troubleshooting it...just delete and try again.

    Set 777 to .htaccess.
    Turned Permalinks off.
    Deleted all entries (except for a comment) in .htaccess (from within WordPress).
    Confirmed that i could now see all the archives.
    Turned Permalinks back on.
    Confirmed everything worked. (yah!!)
    Set 644 to .htaccess.
    Done.

  5. Insom
    Member
    Posted 9 years ago #

    Just for the record, the above procedure did NOT work for me.

    Permalinks and archives do not work.

    Categories, feeds, and search all work, however.

    It's got me beaten. But I'm not turning cruft back on, my site's visitors if any can just suffer until this is fixed :D

  6. Insom
    Member
    Posted 9 years ago #

    It's possibly worth noting that, no matter whether permalinks are on or off, manually typing in

    http://example.com/?m=200503

    works, so, why Apache can't make the connection between that and

    http://example.com/archives/2005/03/

    is entirely beyond me.

  7. shaky
    Member
    Posted 9 years ago #

    I'm getting the same thing. Fix above didn't work either.

  8. ozgression
    Member
    Posted 9 years ago #

    Great, so no-one knows how to fix it?

  9. jpettit
    Member
    Posted 9 years ago #

    is your server configured to be able to do permalinks?...i believe mod_rewrite needs to be installed.

  10. Insom
    Member
    Posted 9 years ago #

    Yes. Mod_rewrite is installed, as evidenced by the fact that categories, pages, etc do work, just that the permalinks and archives do not.

  11. ozgression
    Member
    Posted 9 years ago #

    Mod-rewrite works fine for me... this is a script error, not a server error. I wish people would offer help instead of denying the problem.

  12. niki
    Member
    Posted 9 years ago #

    I have a variation on this:

    Using 1.5 (set to display 10 posts per page with 17 posts made) I get 10 posts on my homepage, a "previous entries" link that takes me to a page with 7 posts and another "previous entries" link that then takes me to the 404 error.

    I have tried deleting entries in .htaccess as above and have also tried it whilst switched to the Kubrick theme.

  13. Elliott
    Member
    Posted 9 years ago #

    FYI,

    I've had so many permalink problems it's not even funny.

    A fix that I've found, is to try different combination of tags - for some reason some combos work and some don't.

    I have 3 WP installs on a server right now, for 3 different domains. One domain, the tags work perfectly, with no /index.php/ needed (mod-rewrite is turned on for the server). On the other two, I need /index.php/. On one of the installs, I tried several tag combos before I found one that worked:
    /index.php/%postname%-%post_id%/

    So play around with different tag combos... WP is quirky... but its nice, customizable and free....

    -Elliott
    http://www.beatleague.com

  14. jessem
    Member
    Posted 8 years ago #

    Guys, if your using Apache, the problem is that AllowOverride directive is not properly enabled. Using /index.php/%postname%-%post_id%/ (or anything else with index.php) is effectively routing around using mod_rewrite. You need to edit your httpd.conf changing "AllowOverride None" to "AllowOverride All" in TWO places not just one:

    i.e. like the wiki says, change:

    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>

    to:

    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory>

    AND, like the wiki doesn't say, (not yet anyway) change:

    # AllowOverride controls what directives may be
    # placed in .htaccess files.

    AllowOverride None

    to:

    # AllowOverride controls what directives may be
    # placed in .htaccess files.

    AllowOverride All

    Reset your permalinks in the options section and bingo! Hope this helps.

  15. jessem
    Member
    Posted 8 years ago #

    I updated the wiki. Just to be clear, the fix for me was enable AllowOverride directive in TWO places:

    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory>

    <Directory /var/www/html>

    (OTHER DIRECTIVES...)

    AllowOverride All

    (OTHER DIRECTIVES...)

    </Directory>

    -Jesse
    http://www.system-calls.com

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags