WordPress.org

Ready to get started?Download WordPress

Forums

Archive pages displaying are displaying all my posts (2 posts)

  1. mediadecay
    Member
    Posted 3 years ago #

    I've been working on my own theme making heavy use of custom post types and custom taxonomies and there just isn't a lot of info surrounding their use after creation. For example this is the problem I've run into right now. Currently my archive pages will display all posts. So I can click on a term in any taxonomy and I get back every post on my site, even if it doesn't use that taxonomy. This is the code for my taxonomy.php:

    http://wordpress.pastebin.com/pK3iEpjC

    Now I had previously thought I had this solved when making my category archives but apparently I didn't. But at least something is going right there (I think because I'm only calling the custom post type that would fit in that category). To explain I have 2 things in the "Film" category one is a regular post and the other is of the cpt "movie_review". Now if I click on the "Film" category I get back those 2 posts plus the "Hello World!" post which is under "Uncategorized". The only reason it's not returning every single post in this case I believe is that I'm only calling the movie_review post type. This is the code I'm using on my category-film.php:

    http://wordpress.pastebin.com/k10nbxqm

    What am I doing wrong? I've googled and searched through every post I can find on here andI cannot find a solution to this anywhere. If you need to see any other source the site is at http://www.jasonfoulke.com/md2/. It's just a test setup with test/dummy content right now. To see examples of the the problem, click a taxonomy like "David Bowie" under artist on the post "Album Review: A Reality Tour" or click the "Film" category on the post titled "Test".

  2. mediadecay
    Member
    Posted 3 years ago #

    Anyone?

Topic Closed

This topic has been closed to new replies.

About this Topic