WordPress.org

Ready to get started?Download WordPress

Forums

Archive by Year permalink returns main blog page (4 posts)

  1. Lokheed
    Member
    Posted 4 years ago #

    Hey guys,

    WordPress archives your posts. But for some reason, it doesn't properly return the "archive by year" page whenever the year is appended to the url. For example:

    http://www.szilveszter.ca/news/2010/

    That jumps to my main blog page. But going to:

    http://www.szilveszter.ca/news/2010/01/

    Returns the proper archive by year and month page.

    I've been trying to figure this out for hours now. To no avail. I just can't see what the problem is!

  2. Lokheed
    Member
    Posted 4 years ago #

    This is getting very strange.

    Changed themes. Problem persists.
    Created new DB. Problem persists.
    Removed everything except for required WP entry in htaccess. Problem persists.

    My install of WP is not in the root and my home page is not my blog. Could this be a WP bug?

  3. Lokheed
    Member
    Posted 4 years ago #

    Okay, so the problem is in WP and Permalinks.

    I have WP installed in /blog/. And through the guide, I've moved WP in the root (moving index.php and putting required lines in htaccess and changed WP address and URL accordingly).

    So I serve a static front page (main) and then my blog is found at news. I've setup Permalinks to use pretty URIs, but that's the problem. I've prefixed them all with:

    /news/%postname%/

    It works fine, but apparently anything I put immediately after news in the address bar, returns the blog page (e.g., dom.com/news/3000/). Not a 404. So it looks like WP can't handle a Permalink pointing to the actual page you use to serve your blog (in my case news). If I change the Permalink structure to the following, it works:

    /news/%year%/%postname%/
    or
    /blog/%postname%/
    or
    /%postname%/

    Still trying to understand the extent of it by playing around with different Permalink structures, but it looks like WP needs a bit of tweaking to work in this manner.

  4. kally14
    Member
    Posted 4 years ago #

    I had the same problem but had already set the structure to /%postname%/.

    I had the "Robots" plugin and found that ticking "Disable the date-based archives" was causing all the problems.

Topic Closed

This topic has been closed to new replies.

About this Topic