WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Registration Options
[resolved] Approval Process Breaks Half Way (6 posts)

  1. hughshields
    Member
    Posted 8 months ago #

    Hello and thanks for the great plugin. I had it working but now it is breaking half way through the approval process. Here is what is going on.
    New User completes registration. Admin receives New User Registration Mail. New user receives validation email and clicks the link. At this point the new user profile is not showing up on the site. As soon as the new user logs into the site the account becomes active and visible to anyone. The user can access all buddypress functions. No mail is ever sent to the admin to ask for approval.

    I am on Buddypress 1.8.1 and WordPress 3.6.1. I have a few plugins running but have tried deactivating almost all and nothing fixes the problem. Any experience with this particular break? Any known plugin conflicts or settings I might be missing.
    Thanks again for the great plugin.

    http://wordpress.org/plugins/bp-registration-options/

  2. hughshields
    Member
    Posted 8 months ago #

    I have isolated the problem. I am using WP User Frontend Pro and the Buddypress Integration Add On to create a custom registration form. When I went back to using the default Buddypress registration form Buddypress Registration Options works again.
    Any ideas why this might conflict?

  3. Michael Beckwith
    Member
    Plugin Author

    Posted 8 months ago #

    Not off the top of my head, but I can install those two myself and try to help prevent/resolve conflicts in the future. Thanks for the tips. :)

  4. hughshields
    Member
    Posted 8 months ago #

    The problem is that my custom registration process sends out a verification email that is not the same as the Buddypress default registration email. Here is the code from my custom registration form:

    // send user notification
                    if ( class_exists( 'Theme_My_Login_Custom_Email') ) {
                        do_action( 'tml_new_user_registered', $user_id, $password );
                    } else {
                        wp_new_user_notification( $user_id, $password );
                    }

    I believe that wp_new_user_notification is not the right email for me to be sending to a new user for email validation. This function sends an an email with username and password details to the new user instead of the verification link.

    What I would like to confirm is whether this is the problem with my registration process not working. Does BP Registration options hook into the verification email sent to the user? When the new user clicks on the verification link is this where BP Registration Options begins to work its magic?

    I am still hunting for the fix to this. If you happen to know the name of the verification email function that you hook into then I would appreciate it!!!
    Thanks
    Hugh

  5. Michael Beckwith
    Member
    Plugin Author

    Posted 8 months ago #

    The way our plugin works is that technically the user gets registered and would have access to *most* of the site, but if it's working like it should, the BuddyPress areas should NOT be accessible. We let them get that far. However, we also set a field in the db for their user, specifically a user_status column. With that value, we deny the access to certain parts and mark them as in moderation. We use just wp_mail to send them notifications about whether they were allowed or denied, but that's all for that part. We also email the administrator so they know a new user came in.

    I think the main difference between your current set up and what we do is the user status part and how far we allow registration to occur.

  6. hughshields
    Member
    Posted 8 months ago #

    Thanks Michael,
    I appreciate the explanation.
    Much obliged!
    Hugh

Reply

You must log in to post.

About this Plugin

About this Topic