WordPress.org

Ready to get started?Download WordPress

Forums

Apply with LinkedIn buttons
Apply With LinkedIn Button Not Displaying (18 posts)

  1. cke11y
    Member
    Posted 5 months ago #

    Hi have just got my API key and also inserted the shortcode but nothing is displaying. I have a screenshot of how it was configured on Linkedin dev site if that helps?

    Please help :(

    cheers
    CK

    https://wordpress.org/plugins/apply-with-linkedin-buttons/

  2. pawprintexample
    Member
    Posted 5 months ago #

    When you set up your API key you have to make sure all of your info is correct.
    where are you displaying the shortcode?

  3. sleblang
    Member
    Posted 3 months ago #

    I am having the same issue. Where should the shortcode be placed, in the text editor?

    Thanks.

  4. pawprintexample
    Member
    Posted 3 months ago #

    Well you're talking about two different things -

    If you want to use LinkedIn Apply Buttons in your template, you must use their code - which is pretty different

    To use the shortcode for this plugin, put it in your post code
    You can try
    <?php echo do_shortcode("[shortcode]"); ?>

    but it might not work.
    You just need to put the API key in the PlugIn Settings in your admin bar, and set your info

    [applywithlinkedin jobtitle="JOB TITLE HERE" companyname="YOUR COMPANY NAME" email="EMAIL ADDRESS HERE" logo="http://yoursite.com/yourlogo.png" themecolor="#ff0000" coverletter="required" size="small"]

    I prefer the code honestly...
    Feel free to message me for help - I'm happy to assist :)

  5. pawprintexample
    Member
    Posted 3 months ago #

    Oh darn, i dont think you can message... ummm - i'll do my best to help here :)

  6. sleblang
    Member
    Posted 3 months ago #

    Thanks for the help! Yes, Just to clarify, I have the API key in the Plugin Settings. I then pasted the shortcode on a test page and when I preview it, nothing shows up.

  7. pawprintexample
    Member
    Posted 3 months ago #

    Have you gone into the LinkedIn API section and added your domain to the application?

    https://www.linkedin.com/secure/developer

    You just need the main URL to your page, nothing special.

    I played it safe though and used the following under OAuth 2.0 Redirect URLs:

    http://DOMAIN.com,https://DOMAIN.com,http://www.DOMAIN.com,https://www.DOMAIN.com,http://www.DOMAIN.com/PERMALINK,https://www.DOMAIN.com/PERMALINK

    Obvs replace the DOMAIN and PERMALINK with your own, if you don't have a permalink on your main URL, then leave the last two domains off the list.
    I also added

    JavaScript API Domains: http://www.DOMAIN.com/PERMALINK

  8. sleblang
    Member
    Posted 3 months ago #

    Thanks. Do I need the url to my page or url for my entire site. I would assume just the url for my site, otherwise an API would have to be created for each job listing OR would I just list the pages on the site where the plugin is being used, i.e. http://www.mysite.com/page1,http://www.mysite.com/page2, etc.

  9. pawprintexample
    Member
    Posted 3 months ago #

    Just to your site.
    I added the Permalinks to mine so I can get a few more Keywords into Google SEO

    so if your site was google, use the following:

    http://google.com,https://google.com,http://www.google.com,https://www.google.com

  10. sleblang
    Member
    Posted 3 months ago #

    So, it's setup just like you state and it's still not showing. Any other ideas as to what the issue might be?

  11. sleblang
    Member
    Posted 3 months ago #

    One more thing to note. I viewed the page source and I see the following:

    <script type="IN/Apply" data-jobtitle="Job title" data-email="myemail@myemail.com" data-companyname="My Company, Inc." data-themecolor="#ff0000" data-coverLetter="hidden" data-size=""></script>

    However, I noticed that I don't see the API key. Is that supposed to be present in the code?

  12. pawprintexample
    Member
    Posted 3 months ago #

    And youre using shortcode? Or placing that script in your template file?

  13. sleblang
    Member
    Posted 3 months ago #

    Is this plugin supposed to work only with the shortcode? Reason I ask is that I was finally able to get it to work using the short code along with adding the this code:

    <script type="text/javascript" src="//platform.linkedin.com/in.js">// <![CDATA[
    api_key: 0123456789ABC
    // ]]></script><script type="IN/Apply" data-jobtitle="Job title" data-email="myemail@myemail.com" data-companyname="My Company, Inc." data-themecolor="#ff0000" data-coverLetter="hidden" data-size=""></script>

    I added this to the HTML portion of the page and it works. If I remove these scripts/code, the button doesn't show. If I keep the scripts/code and remove the shortcode, the button doesn't show.

    I was under the impression, that I just needed to add the shortcode to get it to work.

  14. pawprintexample
    Member
    Posted 3 months ago #

    Yes haha

    The code you entered is the javascript you get from linkedin developers site

    If the script works you dont need the plugin. The plugin just allows you to use shortcode in your posts.

  15. sleblang
    Member
    Posted 3 months ago #

    Thanks, but that's not how it's working. I need both the shortcode and the code from the linkedin developer site to see the button. Also, the email functionality doesn't seem to be working. Am able to apply for position via the button and I receive a notification that I applied. However, the individual listed in the code doesn't receive any sort of notification.

  16. pawprintexample
    Member
    Posted 3 months ago #

    I can assure you, you do not. Try removing the plugin and use linkedins apply via linkedin button generator

  17. martijnh
    Member
    Plugin Author

    Posted 1 month ago #

    Hi,

    sleblang: i don't know if you got it working yet, but we have some bad news: http://wordpress.org/support/topic/new-api-linkedin?replies=3

    Thank you pawprintexample for the support.

  18. martijnh
    Member
    Plugin Author

    Posted 1 month ago #

    Hi,

    sleblang: i don't know if you got it working yet, but we have some bad news: Please see the last post on our support form regarding the new API.

    Thank you pawprintexample for the support.

Reply

You must log in to post.

About this Plugin

About this Topic