WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
[resolved] 'Apply Coupon' button not showing? (5 posts)

  1. azn137
    Member
    Posted 1 year ago #

    This may be a stupid question, but do I need any extension for the 'Apply Button' to show up in the cart/checkout page? Mine's nowhere to be found.

    Thanks!

    http://wordpress.org/extend/plugins/woocommerce/

  2. jameskoster
    Member
    Plugin Author

    Posted 1 year ago #

    You need to enable coupons, 'General' tab on WooCommerce settings screen ;-)

  3. azn137
    Member
    Posted 1 year ago #

    Sorry, I forgot to mention. Yes, the coupon has been enabled in General Settings, and I've set up a test coupon code. I just don't see the field when checking out or viewing cart.

    You can take a look here: http://globalretoucher.com/checkout/

    Please and thank you :)

  4. azn137
    Member
    Posted 1 year ago #

    Anyone?

  5. azn137
    Member
    Posted 1 year ago #

    Okay I think I fixed it. It might've been a theme's bug.

    The code was

    <?php if ( get_option( 'woocommerce_enable_coupons' ) == 'yes' && get_option( 'woocommerce_enable_coupon_form_on_cart' ) == 'yes') { ?>

    And I changed it to

    <?php if ( get_option( 'woocommerce_enable_coupons' ) == 'no' || get_option( 'woocommerce_enable_coupon_form_on_cart' ) == 'no') { return; } else { ?>

    and now it works. Am I right?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic