WordPress.org

Ready to get started?Download WordPress

Forums

Apostrophes in blockquotes not properly displayed (15 posts)

  1. southsou
    Member
    Posted 9 years ago #

    When people make comments on my blog (using comments-popup in WP 1.2.2), apostrophes inside blockquotes are displayed as: �. Outside blockquotes, apostrophes are displayed OK. Does anyone have a suggestion for fixing this problem? Thanks.

  2. marko
    Member
    Posted 9 years ago #

    I have the same problem, but it's not just in comments, it's in the actual posts and it's not just in blockquotes, it's everywhere.

  3. marko
    Member
    Posted 9 years ago #

    I've just discovered that it's also happening with hyphens - dang, just when I thought I'd come across a really good script - does anyone have any idea what is going on with this?
    thanks

  4. URL please...
    Also, what's your text encoding set to?

  5. marko
    Member
    Posted 9 years ago #

    http://www.aussiediary.com/wordpress/index.php?cat=7
    the problem starts at the third paragraph
    thanks

  6. marko
    Member
    Posted 9 years ago #

    hmm, ok, I changed the charset=iso-8859-1 to charset=UTF-8 and the problem has gone - on my browser at least.
    cheers

  7. Good, that's the change that I was going to suggest. Congrats!

  8. southsou
    Member
    Posted 9 years ago #

    Which file conatins the 'charset=iso-8859-1' statement?

  9. Login to your admin interface and go to Options/Reading.

  10. chiensavant
    Member
    Posted 9 years ago #

    @southsou : the index.php files contains this statement...
    And to change the encoding for all pages : Admin > Options > Reading

    It's here at the bottom of the page. Change it to utf-8.

  11. southsou
    Member
    Posted 9 years ago #

    Character encoding in Admin/Options/Reading was already set to UTF-8. My copy of index.php has the following line:

    <meta http-equiv="Content-Type" content="text/html; charset=<?php bloginfo('charset'); ?>" />

    Not knowing where bloginfo('charset') is located, I can't change it.

    However, I think the problem was that several commenters on my blog are using Firefox and did not have their character encoding set to UTF-8. Maybe?

    Thanks for all your help.

  12. NuclearMoose
    Member
    Posted 9 years ago #


    Not knowing where bloginfo('charset') is located, I can't change it.

    Two people already told you where to change this! Read the comments by macmanx and chiensavant. :)

  13. southsou
    Member
    Posted 9 years ago #

    NuclearMoose:

    <b>Calm down, pal</b>. If you actually read my post, you would have seen that I said that UTF-8 was already set in Admin/Options/Reading but I was stilll getting the apostrophe problem.

  14. andyhume
    Member
    Posted 9 years ago #

    My charset is set to UTF-8 in WP options, in the head of all my pages, and in a .htaccess rule.

    Most of the characters are working, but a few - such as opening single quote are not.

    ie. All my #8216 characters are missing in the code - they are all #8217.

    Any pointers?

  15. Kitten
    Member
    Posted 9 years ago #

    Most likely the font that you're displaying the page in doen't have proper support for the character.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.