WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Apostrophes getting stripped from post excerpt (9 posts)

  1. Lewis Rosenthal
    Member
    Posted 1 year ago #

    Excellent work!

    Here's my single complaint:

    My original excerpt reads:

    Proper placement of a variable's definition can be critical in determining whether it will actually be used. In addition, sometimes, these things don't even matter too much in the grander scheme of things, but understanding when, where, and why to set them is always key.

    Yet in the email, I get:

    Proper placement of a variables definition can be critical in determining whether it will actually be used. In addition, sometimes, these things dont even matter too much in the grander scheme of things, but understanding when,
    where, and why to set them is always key.

    I haven't looked at the code to determine where the formatting is taking place or whether this may be as a result of my theme or another plugin which is interacting badly with Subscribe2. Any ideas where to look?

    TIA

    Lewis

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Posted 1 year ago #

    @Lewis,

    Which type of email are you using? Per-post or digest?

    Also, where is the original excerpt? Are you using the Excerpt meta box, a more HTML tag or just letting the plugin handle it?

  3. Lewis Rosenthal
    Member
    Posted 1 year ago #

    Thanks for the quick follow-up, Matt!

    My settings are per-post, plain text, and I'm using the excerpt meta box. Also, I do have the CKEditor plugin installed (but nothing else listed on your conflicts page).

    Lewis

  4. mattyrob
    Member
    Posted 1 year ago #

    @Lewis,

    I've just tested on a vanilla install of WordPress 3.5.2 with Subscribe2 8.9.1. I added a new post with a define excerpt that was copied and pasted from your original post. The apostrophes were present in my email. I suspect a conflict in CKEditor but cannot currently confirm as I'll need to install that plugin manually on my site from home.

  5. Lewis Rosenthal
    Member
    Posted 1 year ago #

    Thanks, Matt.

    I'll also turn off the CKEditor for my next post (I need to set up a sandbox for this stuff, as I'm doing way too much testing on my live site!).

    This has been one of those nagging little things which I just haven't bothered to look into until now. LOL...

    I greatly appreciate your quick and thorough follow-up.

    Cheers

  6. mattyrob
    Member
    Posted 1 year ago #

    @Lewis,

    In the CKEditor->Basic Settings menu do you have the plugin enabled on excerpts or is it disabled?

  7. mattyrob
    Member
    Posted 1 year ago #

    @Lewis,

    Actually I think you must have the CKEditor enabled for excerpts, in that setting it seems apostrophes are HTML encoded so ' becomes &# 39;. These would be stripped by Subscribe2 as they won't look great in a plain text email.

    If you disabled the CKEditor for the Excerpt section it should work fine.

  8. Lewis Rosenthal
    Member
    Posted 1 year ago #

    Indeed, I do have it turned on for excerpts, Matt. Simple enough fix, though, as I really don't need it enabled for those.

    Thanks for having a look, and apologies for putting you to the trouble for something I could have gotten off my lazy *ss to discover for myself! LOL

    $$ coming... Attentive support has become such a rarity these days, and I truly appreciate your time.

    Cheers, and have a great weekend!

    Lewis

  9. mattyrob
    Member
    Posted 1 year ago #

    @Lewis,

    You are very welcome and thanks for the donation.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic