WordPress.org

Ready to get started?Download WordPress

Forums

Apostrophes and quotation marks display as code instead of characters. (10 posts)

  1. BrandBlogger
    Member
    Posted 6 years ago #

    Since just upgrading and then switching hosts, all apostrophes and quotation marks display as code instead of characters. How can I change them in all 200 or so posts w/o editing each one?

  2. tsguitar
    Member
    Posted 6 years ago #

    What do they look like when you try to edit the post? Do they show up as apostrophes and quotation marks when you try to edit or are they code there, too? Is this your post content, the titles, both? Any chance for a link to the trouble?

  3. BrandBlogger
    Member
    Posted 6 years ago #

    tsguitar: They look like three special characters. I erase them and type in the correct symbol ( ' ' ? ) and it comes out right. Don't know about titles, but it's a problem in text and in several sidebar listings. The site is http://www.signaturestrategies.com

  4. tsguitar
    Member
    Posted 6 years ago #

    But the display on the screen as apostrophes and quotation marks. I don't see 8217 on the screen, I see an apostrophe. And when you go to edit the entry, you don't see 8217 on the screen, you see an apostrophe. Is that right?

    WordPress has always converted to XHTML special character codes upon display of the_content. I don't see the trouble you're having.

  5. BrandBlogger
    Member
    Posted 6 years ago #

    tsguitar: I've had a programmer friend look at and fix the problem. But before this, believe me, the finished posts had substituted the actual apostrophes, quotes, question marks with three special characters. I now only have the problem in the "Recent posts" sidebar. Thanks for your help and concern.

  6. tsguitar
    Member
    Posted 6 years ago #

    Since your friend looked at it and fixed it, could you post the solution? What did s/he do to fix the trouble? I never did see anything but apostrophes and quotation marks on your site, so I'm still not sure what the problem was, but just in case someone looks at this in the future, let me know how you fixed it.

  7. BrandBlogger
    Member
    Posted 6 years ago #

    tsguitar: Since I don't understand the lingo or the procedure, I've ask him to come here to describe it.

  8. fotomagia
    Member
    Posted 5 years ago #

    "How's" In any text where exist apostrophe (this sign ' ) in html source changed to this "How’s" And this thing is poor for SEO. How it possible to change? I have WP 2.7 version, but problem still exists.

  9. fotomagia
    Member
    Posted 5 years ago #

    "How's" In any text where exist apostrophe (this sign ' ) in html source changed to this "’" And this thing is poor for SEO. How it possible to change? I have WP 2.7 version, but problem still exists.

  10. fotomagia
    Member
    Posted 5 years ago #

    "How's" In any text where exist apostrophe (this sign ' ) in html source changed to this "# 8217 ;’" And this thing is poor for SEO. How it possible to change? I have WP 2.7 version, but problem still exists.

Topic Closed

This topic has been closed to new replies.

About this Topic