WordPress.org

Ready to get started?Download WordPress

Forums

Apostrophe Issues (6 posts)

  1. SuperSpiker
    Member
    Posted 7 years ago #

    When I publish a post that contains apostrophe wordpress is adding an additional apostrophe.

    For example: If I write

    Joe's Crab Shack
    it becomes
    Joe''s Crab Shack
    when I view the blog post.

    If I edit the post, to fix this problem it adds yet another apostrophe. In fact they keep adding on anytime I edit posts with apostrophes.

    Others are having this issue also see http://wordpress.org/support/topic/44574 however there doesn't seem to be a solution.

    I've started a new blog from scratch with no plugin activated and the problem still exists. I tried 2.0.5 with no success then tried 2.1 alpha 3 just for the hell of it and same issue happens. This leads me to belive that my web host has set an option on Mysql or PHP.

    Anyone with light to shed on this?

    Thanks.

  2. SuperSpiker
    Member
    Posted 7 years ago #

    Bump

  3. moshu
    Member
    Posted 7 years ago #

    And what did your host say - since you suspected it might be related to their settings...?

  4. SuperSpiker
    Member
    Posted 7 years ago #

    They said that I'd need to point them to the problem area of the PHP or MySQL so they can look into it.

    I have no clue about the mysql or php settings so I am unable to guide them to slove the issue.

    Suggestions?

  5. pmilano1
    Member
    Posted 7 years ago #

    I have this same problem. Are the apostrophes doubled up when they go into the db?

  6. pmilano1
    Member
    Posted 7 years ago #

    Turn off Magic Quotes. Seems to do the trick.

Topic Closed

This topic has been closed to new replies.

About this Topic