WordPress.org

Ready to get started?Download WordPress

Forums

Apostrophe in Blog Title rendered #039; in email titles (20 posts)

  1. GuyGallo
    Member
    Posted 4 years ago #

    I have an apostroph in my blog title:

    Screenwriter's Compass

    When a confirmation email is sent to a new user or a broadcast is selt from Alo Easymail, the template for the title of the email comes out as:

    Screenwriter#039;s Compass: etc etc

    Is there a way for this to be fixed? So that the email title either has the apostrophe or it is left out altogether.

    Thanks.

  2. DrewDahl
    Member
    Posted 4 years ago #

    I get the same thing.

    Blog Title: Drew's Blog
    E-mail Subject: [Drew's Blog] Comment: "Fedora 12!"

    Anyone know how to fix this?

  3. doc4
    Member
    Posted 4 years ago #

    GuyGallo,

    This sounds like an issue with Alo Easymail. You might try asking on the forums there for a more timely answer.

  4. GuyGallo
    Member
    Posted 4 years ago #

    I don't think it's Easymail. It happens (and happened before I installed Easymail) with the default mailer.

  5. A fix here: Error with quotation marks: WordPress Themes.

    Add
    remove_filter ('bloginfo', 'wptexturize');
    in functions.php

  6. GuyGallo
    Member
    Posted 4 years ago #

    Nope. When I mail a backup to myself I'm still getting:

    Screenwriter's Compass Database Backup

    And ALO EasyMail sends the same for the blog title.

    I also have "unfancy quote" add-in installed.

  7. From what I can gather, magic_quotes might be on in your server's php config. To find out, make a plain text file and call it phpinfo.php and put just this line in it:

    <?php phpinfo(); ?>

    then put the file in the root of your server, and then go to that file with your web browser. Ssearch for magic_quotes. (If you get an error, that means your server company won't allow phpinfo to run for security reasons.)

    Possible complex fix to replace magic quotes at the server level: Double checking - I should turn off "magic quotes" - Open Blu Host

  8. Daven
    Member
    Posted 4 years ago #

    Has this issue been resolved? I'm having the same problem with my site Daven's Journal.

  9. GuyGallo
    Member
    Posted 4 years ago #

    I have not resolved this issue on my site. Whenever I get an announcement from the blog -- new member or backup -- the title has #039; in the title.

  10. GuyGallo
    Member
    Posted 4 years ago #

    I have not tried songdogtech's suggestion of seeing if this is a server level setting on yahoo.

  11. gtakacs
    Member
    Posted 4 years ago #

    magic_quotes are turned off in php on my server.
    The filter fix is for theme related issues which is not what this is. This is an e-mail issue.

    I can't figure it out for the life of my myself. It just looks so unprofessional.

    If anyone has a solution that'd be great.

  12. gtakacs
    Member
    Posted 4 years ago #

    Update: The problem has to do with how WordPress itself stores the Blog title in its database. It runs attribute_escape() on the value before it inserts it into the database. I think this is a mistake as from this point on the apostrophe is replaced with #039; in the database.

    One solution is to manually edit the wp_options table's blogname entry and replace the #039; with the '. This seems to fix it and doesn't seem to break anything, however I haven't done extensive testing on it but it seems to work for me.

    I have also ran into the same issue with another plugin, Subscribe to comments, that one requires the modification of the source code as it sotres the value correctly but runs it through attribute_escape() upon retrieval from the database.

  13. gtakacs
    Member
    Posted 4 years ago #

    Update: This bug seems to have been fixed in WordPress 2.9

  14. GuyGallo
    Member
    Posted 4 years ago #

    I am running 2.9 and my most recent "backup email" still has the #039; rather than an apostrophe.

    I will try your manual fix.

    Thanks for persisting, gtakacs.

  15. GuyGallo
    Member
    Posted 4 years ago #

    Where is the "wp_options table" to manually edit?

  16. Tom Richmond
    Member
    Posted 4 years ago #

    I also continue to have this issue. Not fixed in 2.9.2

  17. brmoreno
    Member
    Posted 3 years ago #

    I have this issue as well. Any solutions?

  18. groan
    Member
    Posted 3 years ago #

    I am surprised this issue has lived this long...going to check WP_Options now.

  19. groan
    Member
    Posted 3 years ago #

    I changed the apostrophe code to a ' and as soon as I sent a message it went back.

    Can nobody come up with a way to use it in the blog title? I've kind of already started buiding the brand so it would be difficult to go to something else..

  20. groan
    Member
    Posted 3 years ago #

    ok, found it...
    use this instead of the quote

    Fixed for me!
    WOOT!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags