WordPress.org

Ready to get started?Download WordPress

Forums

Apostrophe Backslash - SEO Smart Links Plugin Problem (1 post)

  1. altfgcom
    Member
    Posted 2 years ago #

    Hello,

    I posted this question a few months ago, but didn't get any replies. So, I'm trying again...

    We've been using the plugin "SEO Smart Links." Everything works fine -- except when it comes to apostrophes within the linked keywords or keywords that begin/end in "special characters."

    For instance:
    The Kings Speech will be linked to our URL of choice without an issue.
    The King's Speech will not be linked to anything.

    Marcel Carne will be linked without a glitch.
    Marcel Carné will not be linked at all.

    Alex de la Iglesia will be linked just fine.
    Álex de la Iglesia will not be linked at all.

    One key problem, we believe, may be a backslash preceding the apostrophe (\'). The King's Speech gets "recorded" as "The King\'s Speech" and therefore it doesn't get linked. (Note: This isn't a case of WP inserting curly quotation marks.)

    We're not sure what the issue is with "special characters" either at the beginning or at the end of keywords/phrases. If they're found somewhere in the middle, e.g., "René Clair," it's not a problem.

    Is there a hack to fix that problem? How can we "strip slashes"?? Any idea re: the special character problem?

    If anyone has any idea about either issue, please let us know. That'd be much appreciated.

    [No bumping, thank you.]

Topic Closed

This topic has been closed to new replies.

About this Topic