WordPress.org

Ready to get started?Download WordPress

Forums

API URL Number For YouTube (27 posts)

  1. pea.enter
    Member
    Posted 4 years ago #

    In order to connect my YouTube channel to my blog I need an API URL. In their example it looks something like this: API URL (http://your blog's URL/xmlrpc.php).

    I have my API number.

    My blog URL is: http://make-money-online-marketing.com

    How do I configure my blog's API URL number?

    Here is the page that requires it on YouTube: http://www.youtube.com/account#sharing/blogs

    Click the "Add A Blog" button and then I selected the "WordPress Self-Hosted" under the "Blog Service:" drop down arrow.

    I have everything figured out except exactly what to type in for the "API URL:" field.

    Please help.

    Thank-You,
    Casey Peacock

  2. keme
    Member
    Posted 4 years ago #

    I am also having the same issue. I've tried all possible practical options and I can't figure out what's up?

  3. jeffgswanson
    Member
    Posted 4 years ago #

    Me too. I'm surprised they don't have a link to the answer as they do for the API key.

  4. droy1
    Member
    Posted 4 years ago #

    I finally got it! With a self-hosted WordPress blog you can retrieve the same API key you used for Akismet plugin under Akismet configuration, or in your wordpress.com account. As for the API URL, I used my self-hosted blogs url: http://beachfrontjobs.com/blog and just added /xmlrpc.php at the end of my blog url. Make sure you use your self-hosted credentials for user and password.

  5. kbilly21
    Member
    Posted 4 years ago #

    Hello all -- I've been trying to figure this out for hours today. I think everything is entered correctly but every time I hit "Add Selected Blog" I get this warning:

    "I call shenanigans.
    Must select at least one blog to add."

    ?? No idea.

  6. droy1
    Member
    Posted 4 years ago #

    kbilly21, are you trying to link a self-hosted site?

  7. hbuchwitz
    Member
    Posted 4 years ago #

    I cannot get this to work... but I am wondering if since I have two blogs I need two API keys? Both blogs are self-hosted & on the same domain.

    Thx.

  8. sakyant
    Member
    Posted 4 years ago #

    me too even de activating akismet doesnt work
    looks like you tube cant log in due to wordpress security script measures
    oh well.. its just as easy to open another tab and just edit and post as usual and anyway i need to align and change width on my viedo posts anyway so posting through you tube isnt the best option.. just a little convenient for me when i use my 60 blogger blogs to post to so i dont have to change dashboards all the time
    can live without this for my wordpress self hosted.

  9. julesmoretti
    Member
    Posted 4 years ago #

    So I just did it. And Well I was stuck just like you.

    So this is for a self hosted website. In my case http://www.julesmoretti.com

    so I went to Youtube.com and the blog sharing section
    1. clicked add a blog
    2. made sure it was on wordpress self-hosted
    3. then in onther tab logged in to my actual blog (www.julesmoretti.com with a admin user of course) and then went to
    3.A: Plugins => Akismet Configuration
    3.B: I copied the valid API Key
    4. Pasted the API key from my blog to youtube config page
    5. Finally for the API url used "pea.enter" first comment at the top of this current forum config and did http://www.julesmoretti.com/xmlrpc.php

    And believe it or not but when I clicked ok it accepted it!!! Woop woop.

    I hope this will help. Sorry if it does not. See ya. And drop me a line on my website.

    Jules

  10. joemcneal
    Member
    Posted 4 years ago #

    This particular forum seems to have all the right answers and yet I'm still stuck.

    WordPress self-hosted, check!
    Username: admin
    Password: check!
    API URL: my blog's url with /xmlrpc.php check!
    API Key: check!

    I'm sure everything I entered is correct and tried different variations to try to get it to accept yet, nothing will work. Oh well.

    The most annoying thing of all is the error message that comes up telling me what I need to fix, which is...

    "An error has occurred. Message: Unknown"

    Doesn't exactly help very much.

  11. heatherinbeautifulbc
    Member
    Posted 4 years ago #

    Oh, I just went through this whole annoying process and was about to give up. I followed everything you all said above and nothing worked - I kept getting the "Shenanigans' message. Finally, when that came up I thought I'd just click on over to my blog through the highlighted blue blog url that was shown in the message. It took me to my blog of course, then I hit the green back arrow at the top of my screen - et voila - my blog is setup!

    Weird - just totally weird....

    Jules, you should be writing instructions for WordPress users - you were very precise and exact - and you made sense when you laid it all out for us!!! Sometimes the techies who write the directions forget us newbies don't KNOW how to find the info we need.

    Thanks for your help! See you on YouTube :)

  12. RxMDMarketingPro
    Member
    Posted 4 years ago #

    For all those following julesmoretti's excellent instructions and your still getting failure. I think I know your issue. Try this:

    Log in to your self hosted wordpress account.
    Click "Settings" then
    Click "Writing"
    Under the "Remote Publishing" heading look for - XML-RPC
    and check the box next to the text that reads "Enable the WordPress, Movable Type, MetaWeblog and Blogger XML-RPC publishing protocols."

    Save your settings, and viola...it will work, I was banging my head against the wall until this dawned on me.

  13. iron1
    Member
    Posted 4 years ago #

    This worked for me :) Thanks to all who helped in this thread!

  14. hellojustinoh
    Member
    Posted 4 years ago #

    I was getting the whole "Shenanigans" error too and did exactly what heatherinbeautifulbc did and it worked perfectly. Weird, but it works! Thanks

  15. KristenE
    Member
    Posted 4 years ago #

    Thank you to julesmoretti and RXmdmarketingpro - it finally worked.

  16. julesmoretti
    Member
    Posted 4 years ago #

    I am glad I was helpful and so was RXmdmarketingpro. The pleasure is mine.

    Have fun...

  17. rabbimelinda
    Member
    Posted 4 years ago #

    I keed getting this message in the youtube setup:

    Friendster: Your username is your email address.
    WordPress.com: Requires your blog's url (blogname.wordpress.com) if it is not username.wordpress.com

    what to do???

  18. rabbimelinda
    Member
    Posted 4 years ago #

    i changed the settings and tried using these url's:

    http://holisticdivorcecoaching.com/xmlrpc.php
    http://www.holisticdivorcecoaching.com/xmlrpc.php

    here's the message I got.

    Specific Blog Host Requirements:
    Friendster: Your username is your email address.
    WordPress.com: Requires your blog's url (blogname.wordpress.com) if it is not username.wordpress.com.
    WordPress Self-Hosted: Requires an API key and the API URL (http://your blog's URL/xmlrpc.php).

    suggestions?

  19. corkgraham
    Member
    Posted 4 years ago #

    I'm getting this same problem:

    "Friendster: Your username is your email address.
    WordPress.com: Requires your blog's url (blogname.wordpress.com) if it is not username.wordpress.com"

    what to do???

    And I did all the suggestion provided above: setting, API key, API URL--what gives?

  20. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    If you have your own self-hosted WP site, then you should choose "WordPress Self-Hosted".

    The API URL is your blog's address + xmlrpc.php. Like this: http://example.com/blog/xmlrpc.php

    The API Key is irrelevant, ignore it or fill it in with gibberish, it doesn't matter. We've told them about this before, they never have fixed it. Self-hosted blogs do not need an API Key for YouTube.

    You'll also need to install the YouTube brackets plugin on your site, you make YouTube's post features work properly.

    Also, on your blog's Settings->Writing page, turn on the XML-RPC setting.

  21. corkgraham
    Member
    Posted 4 years ago #

    Thanks, Otto42. Also included your actions, and uploaded YouTube plugin and still same error message:

    "An error has occurred. Message: Unknown"

  22. franchisesolutions
    Member
    Posted 4 years ago #

    Thanks to RXmdmarketingpro and julesmoretti !!!

    I hope someone in WordPress Support will take note of julesmoretti's and RXmdmarketingpro's correct answers. After searching the WP forums for the past two hours I know there are a lot of frustrated users who need this info.

  23. clhmedia
    Member
    Posted 4 years ago #

    @ RxMDMarketingPro I cant believe i forgot the most important step. i guess you cant publish much via XML-RPC if the XML-RPC option is disabled... DUH thanks again

    for all those that may come here lost, make sure you do what RxMDMarketingPro says, then follow julesmoretti's instructions

  24. momentscount1
    Member
    Posted 4 years ago #

    YES! Follow the instructions from RxMDMarketingPro for that last little (or first little) crucial step! It works!

  25. savvy.chick
    Member
    Posted 4 years ago #

    Thank you to all contributors for these helpful & timesaving pointers.

    I thought to post a couple little additions of my own:

    * Before selecting the final 'Add Blog' button in You Tube, ensure you've logged out of WordPress (otherwise it just whirs round and round doing nothing).

    * If anyone's trying to do this who has a static WordPress homepage, rather than a blog WordPress homepage, I confirm it's is still the root domain that YouTube is after for the API URL, ie: use http://example.com/xmlrpc.php, not http://example.com/my-blog-contents-page/xmlrpc.php. Or at least, that's what finally worked for me!

  26. deepconnectionnet
    Member
    Posted 4 years ago #

    Thank you all for sharing your experience on this, particularly to RxMDMarketingPro and heatherinbeautifulbc

    I got stuck for hours with it and then I followed your information. It worked! My blog http://www.deepconnection.net is now linked to my YouTube. I am so happy!

    Thanks again

  27. Jaffasoft
    Member
    Posted 4 years ago #

    I believe this service has been taken away from youtube. Just when i finally found some info on how-to after a year :(.

    It isn;t any wander with the difficulties it was.

    Some brilliant info came from some ppl here b.t.w.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags