Ready to get started?Download WordPress


api key + api url (8 posts)

  1. slickuser
    Posted 6 years ago #


    I hosted WordPress on my domain.

    I also register an account at wordpress.com and got the api keys.

    When I enter the api key with api url (http://mydomain.com/wordpress/xmlrpc.php) through youtube blogger (WordPress Self-Hosted).

    I get an error while trying to add my blog.

    An error has occurred. Message: Unknown

    Any idea? thx

  2. johnsdr
    Posted 5 years ago #

    Is there any solution to this?

  3. johnsdr
    Posted 5 years ago #

    can someone please help with this?

  4. Ashley Bolivar
    Posted 5 years ago #

    did you ever figure this out? I am having the same issue and could also use some help.


  5. campmozart
    Posted 5 years ago #

    We share the same problem.

    Is there a way of telling exactly what the API url should look like? Some say http://wheteveryourdomainnameis.com/wordpress/xmlrpc.php others say http://wheteveryourdomainnameis.com/xmlrpc.php still none of them seem to work.


  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Your API URL will be whatever your blog's URL is with xmlrpc.php added at the end. The exact form will depend on whether you installed the blog in a subdirectory or not.

    Way to test: put the URL in a browser. You should get a message that says "XML-RPC server accepts POST requests only." That'll be the right URL.

    You also need to enable XML-RPC on the Settings->Writing page.

  7. keme
    Posted 5 years ago #

    Ohhmigoodness - this worked! THANKS, a kachillian...

  8. jeffgswanson
    Posted 5 years ago #


    I've been looking for this answer everywhere and you finally answered it.

    Big thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic