WordPress.org

Ready to get started?Download WordPress

Forums

API endpoint (36 posts)

  1. mi327
    Member
    Posted 9 years ago #

    Flickr asks for an API endpoint. It gives an example for all worpress users

    Note: WordPress users, your API Endpoint is
    http://your.blog.address/wordpress/xmlrpc.php

    but when I use this example it says that my endpoint was incorrect.
    what is an API endpoint?

  2. Kafkaesqui

    Posted 9 years ago #

    Your xmlrpc.php file should be located at:

    http://www.shortforstephen.com/xmlrpc.php

    Did you not upload this file with your WordPress installation?

  3. kgeiger
    Member
    Posted 9 years ago #

    Same issue, I was unaware that wordpress had an xmlrpc in the installation. Mine didn't unzip with all the other stuff. Is there a way to get this file?

  4. rockychen
    Member
    Posted 9 years ago #

    mi327:
    I came across the same problem as you did. So what shall I do? I get my blog from blogsome.com which is powered by WordPress.

  5. mi327
    Member
    Posted 9 years ago #

    I just upgraded and WP1.5 has it.

  6. Jackonth
    Member
    Posted 9 years ago #

    Mine is there. I looked in the folder but I still get that error message.
    Anyone?

  7. piwacket
    Member
    Posted 9 years ago #

    I am also recieving an error on trying to add my blog to Flickr. "The endpoint you entered was not correct." When I added www. to the beginning of my url, it was fine.

  8. AndWat
    Member
    Posted 9 years ago #

    The xmlrpc.php thing worked for me in setting up a "Perspective" from iUpload. Unfortunately, the perspective got a little distorted from that point on. If you're interested in more, the relevant post to my iUpload blog is at:
    http://andwat.iuplog.com/default.asp?item=91672

  9. fobusboy
    Member
    Posted 9 years ago #

    it should be located in your wordpress installation directory.

  10. masquerade
    Member
    Posted 9 years ago #

    If you're sure its there and you're still getting errors, be sure you are running the latest version of WordPress, as xmlrpc has undergone a great deal of change due to a security vunerability.

  11. moondreamsnet
    Member
    Posted 9 years ago #

    i have a hosting plan where i set up some "add-on" domains in cpanel. the main site is http://www.moondreams.net. the add on is http://www.whatever.net. on whatever.net, i set up a subdomain called tony. the tony folder is under the main moondreams.net site, so i can either go to tony.whatever.net or http://moondreams.net/tony/ to get to that site. entering http://tony.whatever.net/xmlrpc.php didn't work, probably due to some htaccess rewrites or something. so i tried http://www.moondreams.net/tony/xmlrpc.php and i worked fine.

    note: i don't really own "whatever.net" - that's just an example since i'm still working on the actual domain.

    -jim

  12. moondreamsnet
    Member
    Posted 9 years ago #

    one more thing - i just tested it and it didn't work the first time. following the advice on flickr that "web services are sometimes flaky," i clicked the "try again" button and it posted. so don't get discouraged the first, second, third ... hundredth time. just try again.

  13. digink
    Member
    Posted 9 years ago #

    I had the same problem, and that's because I have my WP installation in a different directory. Flickr tells you to use http://www.yoursite.com/xmlrpc.php and mine is actually in http://www.yoursite.com/wp/xmlrpc.php.

    I added the directory in, and it worked.

  14. Dextrine
    Member
    Posted 9 years ago #

    I having the same problem. I have two installations of WordPress. The one I'm trying to get working is running 1.5. Why is this not working? I'm sure it's the right folder and file. Why is this not working as it should!?!

  15. drobbins
    Member
    Posted 9 years ago #

    I have been having this problem for days now and can't fix it - if xmlrpc.php is in my site root folder, it won't work, but if it is in a subdirectory it will ... I wonder if setting up a redirect to it will work, or if I'm going to have to change the code itself trying to ping to it?

  16. Dextrine
    Member
    Posted 9 years ago #

    I'm also getting desperate with this problem. To some it works and to some it does not. I'd really appreciate if someone would give a reason to this. I've tried to put the xmlprc.php file to a subfolder, but that does not help at all. :( Pretty mysterious shit.

  17. Dextrine
    Member
    Posted 9 years ago #

    Not that I have the latest and greatest Wordress xmlrpc.php. I really just don't have any ideas.

  18. stchatterbox
    Member
    Posted 8 years ago #

    I'm having the same problem. It kept saying my endpoint was incorrect... ...I changed the permission of xmlrpc.php to 666 then to 755, 777 etc....still it does not work.

  19. mollysummer
    Member
    Posted 8 years ago #

    I am also having this problem. I have the latest WP, and I am looking at the file in my root folder, but not getting any results from the flickr form-just the enpoint is not correct error.

  20. dhkeller
    Member
    Posted 8 years ago #

    check your caps/CAPS in the names of the files called by the xmlrpc file. "class-IXR.php" in your wp-includes folder needs to match case with the call inside xmlrpc. I fixed that, and it finally worked for me.

  21. stchatterbox
    Member
    Posted 8 years ago #

    it's just the same. dhkeller. nothing works......

  22. nikolaibailey
    Member
    Posted 8 years ago #

    Might didn't work for ages then I tried it in Internet Explorer 6 (not Firefox as I was before) and it worked. Worth trying though odd that it wouldn't work in Firefox.

  23. jennifre
    Member
    Posted 8 years ago #

    I'm trying to get flickr to work, as well. It won't find the api endpoint. But, I think it's because something is wrong with my xmlrpc file.

    http://www.exciting.cc/xmlrpc.php

    anyone know how to fix this? my hostee doesn't have a problem (http://miss.exciting.cc/xmlrpc.php) and i installed her wordpress just as i did with mine.

  24. bkk
    Member
    Posted 8 years ago #

    To echo what has been said: I am unable to get get flickr to post to wordpress. I currently have WP 2.0.1 installed in a subdirectory (e.g. http://www.domain.com/wordpress). I can call the xmlrpc.php file from the browser and I do get message saying "XML-RPC server accepts POST requests only." When I try from flickr I get "The endpoint you entered was not correct." I ran a test to see if I could post to my test blog on wordpress.com and it seems to work fine. Has anyone come up with a resolution to this issue? Thanks..

  25. bkk
    Member
    Posted 8 years ago #

    I have sites on two different servers and I was able to post from flickr to one server but not the other. After going through this with tech support at my hosting company they commented out the following mod security rule:

    SecFilterSelective HTTP_Content-Type "!(^application/x-www-form-urlencoded$|^multipart/form-data;)

    I am now able to post to both sites.

  26. toopicky
    Member
    Posted 8 years ago #

    BKK:

    Where did you make this change?

  27. danostuporstar
    Member
    Posted 8 years ago #

    I also had this problem in Firefox, but it worked fine in IE.

  28. Carrie
    Member
    Posted 8 years ago #

    I am running WP 2.0.2. My blog is installed to my root.. http://www.ponderethereal.com. I have verified that xmlrpc.php is actually in that directory. Flickr tells me that the endpoint is not correct. I tried with and without the www - although the blog is set up with the wwww. I tried changing the permissions on the file - that didn't help.

  29. michaelramm
    Member
    Posted 8 years ago #

    I was having this problem using FF. I switched to IE like dano, and it worked like a charm.

    Guess we HAVE to keep IE around for a few things. :-(

  30. eija
    Member
    Posted 8 years ago #

    Nope... I can't get it to work. Not in Firefox, IE or Opera. Tried all of them. I've changed the folder and file permissions into 777 - no help. I've tried all possible (and impossible) api addresses. The xmlrpc file is located where it should be.

    The funny thing is, that I have two sites from the same service provider: In URL A I have three blogs (WP 2.0) and Flickr works just fine. When I installed WP 2.0.2 there, it worked without problems, too, with Flickr. URL B is newer, and when I install wordpress there, the blog works just fine, but Flickr doesn't accept the api endpoint.

    So I guess it must be an issue with the server side...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.