WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
apc, memcached, page, db & object cache enabled, but search is still slow (1 post)

  1. niska
    Member
    Posted 1 year ago #

    I'm using W3 Total Cache 0.9.2.4 on a dedicated server with nginx and APC and memcached enabled.

    Page Cache: disk
    Database cache: memcached
    Object cache: memcached

    For homepage, posts and pages everything is fast as lightning (almost). But when doing search (or something else that will not fetch the page from cache) the page takes about 1.2 - 1.6 seconds to be created.

    To find out the reason, I've enabled debug info. And it says:

    <!-- W3 Total Cache: Object Cache debug info:
    Engine:             memcached
    Caching:            enabled
    Total calls:        4466
    Cache hits:         4457
    Cache misses:       9
    Total time:         0.2191
    
    <!-- W3 Total Cache: Db cache debug info:
    Engine:             memcached
    Total queries:      21
    Cached queries:     21
    Total query time:   0.0116
    
    <!-- W3 Total Cache: Page cache debug info:
    Engine:             disk: enhanced
    Cache key:          _index.html
    Caching:            disabled
    Reject reason:      Requested URI contains query
    Status:             not cached
    Creation Time:      1.282s
    Header info:
    X-Pingback:         http://www.domain.com/xmlrpc.php
    Content-Type:       text/html; charset=UTF-8
    X-Powered-By:       W3 Total Cache/0.9.2.4

    As you can see object cache takes 0.2191 seconds and database cache takes 0.0116 seconds. But creation time for the page is 1.282 seconds.

    How can I find out why the page creation time is 1.282 seconds? It doesn't seem normal.

    http://wordpress.org/extend/plugins/w3-total-cache/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic