WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Apache segmentation fault with WordPress 2.1 (13 posts)

  1. mfauveau
    Member
    Posted 7 years ago #

    Hi folks,

    I usually don't need help with WordPress has I'm a PHP developper myself but this time I really need some help.

    I have this website http://www.wiik.fr that was on WP 2.0.2. Yesterday I've upgraded it to WP 2.1. Since that, every time there is a hit on the site, Apache generate a segmentation fault.

    Like this :
    code
    [Thu Jan 25 17:46:44 2007] [notice] child pid 2114 exit signal Segmentation fault (11)
    free(): invalid pointer 0x8507f68!
    code

    Even if the error itself don't seems to cause problems on the website itself, Apache will user 95% of the server CPU after a certain time. And that, is very very annoying.

    I'm running Apache 2.0.54 with mod rewrite and mod ssl enabled. PHP is 4.3.10 (with no specific modules) and MySQL is 4.1.11. All of theses are on Debian Sarge (stable).

    Any ideas ?

    Regards,
    Matt.

  2. mfauveau
    Member
    Posted 7 years ago #

    Am I the only one with this problem ?

  3. mfauveau
    Member
    Posted 7 years ago #

    I have upgraded PHP to 4.4.4 and did an apt-get upgrade. Everything seems to work well now.

    I bet one of the file on the serveur was not up to date.

  4. baptiste
    Member
    Posted 7 years ago #

    I'm seeing the same problems with 4.3.10 - Numerous segmentation faults, sometimes on successful page loads, other times, I get a blank page. This is only on my one 2.1 WP install. All the 2.0.x WP installs function normally.

    Sigh - well, I've needed to update php for a while anyway.

  5. quickie
    Member
    Posted 7 years ago #

    Same problem here upgrade from 2.0.7 to wp2.1
    The server is running PHP 4.3.10-18 and Apache/2.0.54

    i get tons of:
    (32)Broken pipe: core_output_filter: writing data to the network
    child pid 3943 exit signal Segmentation fault (11)

    the website is only rendered partially.

    strange fact: this is the only wp 2.1 on my server that keeps on crashing. all other instances run fine

  6. akamust
    Member
    Posted 7 years ago #

    i'm thinking about all servers around the world using debian stable. no way to get wordpress 2.1 working fine on debian stable, since php 4.3.10-18 is *the* php version available.

    hope problem gets fixed pretty soon...

  7. davidchait
    Member
    Posted 7 years ago #

    Sounds like a PHP issue, not sure how/if WP core dev team can resolve an issue like this (they'd have to figure out what precisely was causing the issues, and whether there's actually a way to work around them... and given it's apache/php crashing, doubtful they'd invest much time...).

  8. akamust
    Member
    Posted 7 years ago #

    disabling widgets plugin, i don't get segmentation fault anymore. hope it helps developers...

  9. akamust
    Member
    Posted 7 years ago #

    uh, wait guys. did you update widgets plugin? i just did it, and it seems i have no problems anymore (if i'm wrong, i'll let you know, of course).

  10. akamust
    Member
    Posted 7 years ago #

    well, i'm sorry, but updating widgets plugin don't fix the problem. disabling widgets does...

  11. w1nn3
    Member
    Posted 7 years ago #

    omg, finally found this topic.
    I'm struggling w/ that error for more than 2 weeks now.
    Apache/2.0.54
    MySQL 4.0.24_Debian-10sarge2-log
    PHP 4.3.10-18
    I've looked into mod_status, this is what I found:
    The problematic childs are always handling requests from microsoft, yahoo and google. "GET /2006/05/07/ HTTP/1.0"
    It's always about getting dailyarchives.

  12. mfauveau
    Member
    Posted 7 years ago #

    Seems like PHP 4.3.10-18 as some compatibily issues...

  13. akamust
    Member
    Posted 7 years ago #

    i just upgraded to wp 2.1.1 and it *seems* like there are no segfault anymore... (who knows, maybe they were wrong?)

Topic Closed

This topic has been closed to new replies.

About this Topic