WordPress.org

Ready to get started?Download WordPress

Forums

Apache LimitRequestFieldSize directive can harm WP (4 posts)

  1. Simonech
    Member
    Posted 8 years ago #

    I just found out an Apache directive that can be a problem for WP on hosted environments: LimitRequestFieldSize

    This directive limits single fields size, and is set to 8190 bytes by default

    I noticed this because, using the various *-editor.php files I can edit small files, but not big ones.

    Also the default LimitRequestFieldSize is 8190, which prevent files bigger than 8k to be edited...
    I think this can also prevent postings of big posts, too...

    How to workaround this?

  2. Mark Jaquith
    WordPress Lead Dev
    Posted 8 years ago #

    Change the setting, or ask your web host to do so. Or, if neither is possible, consider changing hosts... that's a crazy thing for them to do. WordPress isn't going to be able to fix this, unfortunately.

  3. Simonech
    Member
    Posted 8 years ago #

    Yes, I asked it to the host.
    But the problem is that the default Apache settings (ie if the host admin doesn't change things) is 8190bytes (8kb).

    In my opinion this it too small, and if WP has the power to do so, they could has Apache to have an higher defaul setting.

    and also, maybe put a FAQ somewhere explaining that problem.

  4. PhpClases
    Member
    Posted 8 years ago #

    same problem here
    is a "problem" from Apache config by default
    Im trying to put a new LimitRequestFieldsize "2097152" in httpd.conf
    and when i start the server from the command line:

    Syntax error on line 546 of /etc/httpd/conf/httpd.conf:
    LimitRequestFieldsize "2097152" must not exceed the precompiled maximum of 8190

    so you need to recompile Apache, and is work for a server administrator not a coder :(

Topic Closed

This topic has been closed to new replies.

About this Topic