WordPress.org

Ready to get started?Download WordPress

Forums

Apache internal redirects error (1 post)

  1. sdoss
    Member
    Posted 3 years ago #

    Just installed WordPress 3.04 as a multi-site using sub-directories. After a rather painful process (my fault, no one else's) I believe the network is appropriate, and apache configured appropriately. Although I have not mapped domains, yet, I can still access the individual sites via browser using url http://www.mywordpress.com/sitename. Worked marvelously this morning (well, yesterday, since it's well after midnight). Approx. 5 pm yesterday, the pages began loading incredibly slowly.

    Have watched the error log for apache (the default log), and am seeing lots and lots of the following error:

    [Fri Feb 11 00:16:06 2011] [error] [client <myipaddress>] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get
    a backtrace., referer: http://www.mywordpress.com/

    Additionally, getting to wp-admin and moving around it's areas take an extremely long time (3-5 minutes per page display). Same message as above, with the referer portion reading

    referer: http://www.mywordpress.com/wp-admin/ms-themes.php

    I've found numerous references to the errors, most of these references refer to the .htaccess file. Here's mine:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    The wordpress site is the only site on the server causing these errors. I occasionally get an error for a missing image (which I know is not there), which shows in the error log right before the page actually displays.

    And the error log for http://www.mywordpress.com shows no errors.

    I'm open for suggestion - what do I look for? Where do I look?

Topic Closed

This topic has been closed to new replies.

About this Topic