WordPress.org

Ready to get started?Download WordPress

Forums

Apache directory lsiting... Indexof/wordpress (6 posts)

  1. Louis
    Member
    Posted 9 years ago #

    Hello I just installed Apache2, php4.4, and MySQL 4.1 on my winxp pro Pc at home to get wp running. I simply dropped the folder in the htdocs dir. named "wordpress."

    I edit and save the config file, then when I go and access the site I get the directory listing like so:

    Index of /wordpress
    Name Last modified Size Description-------------------------------------------------------------------------------- Parent Directory -
    index.php 13-Feb-2005 19:38 95
    license.txt 01-Apr-2003 13:12 15K
    wp-admin/ 27-Aug-2005 10:20 -
    wp-atom.php 09-May-2005 11:11 1.9K
    wp-blog-header.php 13-May-2005 21:07 8.4K
    wp-comments-post.php 03-May-2005 07:31 2.3K
    wp-commentsrss2.php 14-Aug-2005 18:21 3.3K
    wp-config-sample.php 21-Feb-2005 05:38 840
    wp-config.php 27-Aug-2005 10:21 830
    wp-content/ 27-Aug-2005 10:20 -
    wp-feed.php 29-Mar-2005 14:05 762
    wp-images/ 27-Aug-2005 10:20 -
    wp-includes/ 27-Aug-2005 10:20 -
    wp-links-opml.php 22-Mar-2005 20:57 2.3K
    wp-login.php 26-Jun-2005 16:27 9.6K
    wp-mail.php 01-Feb-2005 12:21 5.5K
    wp-pass.php 13-Mar-2005 15:36 299
    wp-rdf.php 21-Feb-2005 03:19 2.3K
    wp-register.php 19-Apr-2005 03:35 6.4K
    wp-rss.php 21-Feb-2005 03:19 1.3K
    wp-rss2.php 24-Feb-2005 17:29 2.1K
    wp-settings.php 15-Aug-2005 03:57 5.7K
    wp-trackback.php 20-Apr-2005 22:06 3.0K
    wp.php 14-Feb-2005 03:36 1.9K
    xmlrpc.php 14-Aug-2005 18:06 37K

    then I see the wordpress logo then the install instructions under it. I installed it, but I always get this page, each time I try to browse the site. How can I correct this issue. It wont let me login or show the index.php page. I'm stumped, any help would be greatly appreciated.

    -Louis

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Put this into your apache http.conf file:
    DirectoryIndex index.php index.php4 index.php3 index.cgi index.pl index.html index.htm index.html.var index.phtml

    (It's all one line)

  3. Louis
    Member
    Posted 9 years ago #

    Podz thanks. Doh! forgot to do this, when I added the php info and stuff. thanks it is working now.

  4. tcochran
    Member
    Posted 9 years ago #

    Podz, I have a similar problem. I have a new WP install on an Apache server with mod_rewrite working. I was able to add a blank .htaccess file and get WP to update the Permalink structure. I also added "Options +Followsymlinks" at the top of the .htaccess file. But the Permalinks still do not work. Where do I find the apache http.conf file, so that I can add your DirectoryIndex line to it?

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    That entirely depends where your server is - but adding that line into a .htaccess has the same effect.

    On my domains, I have no access to the .conf file - I use xampp on XP though where I do access it for local setups.

  6. tcochran
    Member
    Posted 9 years ago #

    Podz, adding that line to .htaccess worked. You're my hero! Thanks a lot!!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.