WordPress.org

Ready to get started?Download WordPress

Forums

Anyone Get WP to Run On IIS 6.0? (6 posts)

  1. garymich
    Member
    Posted 5 years ago #

    I am sure others have encountered and overcome this problem. I have installed and verified the installation for PHP 5.2.9-2 and MySql 5.0.67 and both are installed correctly. I have supplied the correct values in the wp-config.php file. I have checked and double checked all of this and am positive that I have it correct.

    Now the problem, I browse to http://www.mysite.com/wordpress/wp-admin/install.php and enter the name of my blog, my email address and click the Install WordPress button and I get the following error:

    The page cannot be displayed
    You have attempted to execute a CGI, ISAPI, or other executable program from a directory that does not allow programs to be executed.
    --------------------------------------------------------------------------------

    Please try the following:

    Contact the Web site administrator if you believe this directory should allow execute access.
    HTTP Error 403.1 - Forbidden: Execute access is denied.
    Internet Information Services (IIS)

    So I have used IIS to grant execute access on the wordpress, wp-admin, wp-content and wp-includes folders and still get the same error. Being stubborn I have not yet given up so I set the ntfs privileges to allow shared web access with execute privleges for the previously mentioned folders.

    Still get the sasme freakin error! What am I doing wrong? I am sure many others have successfully installed and configured WordPress on Windows Server 2003 and IIS 6.0.

    Any help would be greatly appreciated.

  2. crisn
    Member
    Posted 5 years ago #

    Hi there. I'm just wondering what would be the issue if you uprade your IIS version. As far as I know, WP isn't compatible with IIS 6.0. I'm using GoDaddy and upgrading to IIS 7.0 was just easy. (I just hope that their ticket response is as quick)

  3. garymich
    Member
    Posted 5 years ago #

    Hi. Fortunately for me it would not be asn issue as the servers I am trying to install on are mine or are leased by me and as such I have full administrative priveleges on them. I think I will try upgrading to IIS 7.0 on one of the servers and see if that solves the problem.

    Thanks for the suggestion.

  4. garymich
    Member
    Posted 5 years ago #

    OK, I guess that nobody has been able to get this configuration to work or they just aren't ready to share how they managed to accomplish it. I'm not a server guy but have have installed plenty of .net sites on iis 6 & 7. I think I have a solution! I'll use a .net open source blogging solution and stop wasting my time!

    Cheers and good luck.

  5. ruslany
    Member
    Posted 5 years ago #

    The easiest way to install WordPress on IIS 6.0 (as well as any other IIS version) is by using the Microsoft Web Platform Installer. Just go to this page and click on the green button to start installation. All the necessary components and configuration steps will be done automatically.

  6. rjacobsen
    Member
    Posted 4 years ago #

    My setup uses IIS 6, FastCGI and PHP. After almost a week trying everything possible to get rid of the 403.1 error and frustrated to read forums where mostly everyone had it fixed by changing permissions settings that I had already applied, I found that my mapping for .php read "GET, HEAD, POST", when there shouldn't be any spaces between words. As I had to type when setting it up, I automatically did it with spaces. If nothing else solved your problem, this could be it.

    To access this setting, in case you don't remember (you must have been there if you already setup PHP), right-click on My Computer, choose Manage, under Services and Applications, Internet Information Services Manager, Web Sites, right-click on your WordPress folder/virtual directory, Virtual Directory tab, Configuration button, select .php and Edit...

Topic Closed

This topic has been closed to new replies.

About this Topic