WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Anyone Get This To Work (10 posts)

  1. Daniel Craig Jallits
    Member
    Posted 6 years ago #

    I am receiving the following error in my WordPress Dashboard when using the Dreamhost Shared Hosting CPU Usage plugin.

    Dreamhost Shared Hosting CPU Usage:
    * You have to activate CPU monitoring. Check out how here.

    CPU Monitoring has been activated for over a month. I also checked and can verify that data is being recorded by looking into my logs/resources folder.

    I have the recommended .htaccess file in the root folder of my site even though WordPress is in a sub-folder.

    Anyone else have any luck with this? Are there any suggestions?

  2. bernabauer
    Member
    Posted 6 years ago #

    hi there jallits!

    Can you check the location of the logs/resources folder?

    it should be in "/home/your-username/logs/resources" and the file should be named "your-username.sa.analized.0"

    Another thing you can check to help me diagnose the problem is if your WP installation is located in a subfolder.

  3. Daniel Craig Jallits
    Member
    Posted 6 years ago #

    Location is correct. It is in /home/your-username/logs/resources

    WordPress address http://mydomain.com/assets/wordpress
    Blog address (URL): http://mydomain.com/

    My .htaccess file is located at the root of the blog address.

    I can view my CPU statistics at http://mydomain.com/stats/ therefore I believe the problem is outside of DreamHost

  4. bernabauer
    Member
    Posted 6 years ago #

    Hum... I think i figured out the problem. The message was generated by a test that pointed to a relative directory that only works with a given path.

    I updated to 0.9.1. This should fix the message issue.

    Any other problem or suggestion, please, drop me a line.

  5. Daniel Craig Jallits
    Member
    Posted 6 years ago #

    Updated to 0.9.1 but still have the issue. I provided below what I receive from the CPU Usage Options page.

    Dreamhost Shared Hosting CPU Usage:
    * You have to activate CPU monitoring. Check out how here.

    Last 7 days CPU usage

    Date CPU Seconds Plugins
    2008-02-10 0 5
    2008-02-09 0 5
    2008-02-08 0 5
    2008-02-07 0 5

    If the direct link to raw CPU usage does not work, you should read this.

    Next CPU usage fetch : 12/02/2008 10:00:00

  6. bernabauer
    Member
    Posted 6 years ago #

    hum! I finishd installing a WP in a subfolder just like yours and got no problem.

    Can you check if the address below works for you?

    http://your-domain/stats/resources/your-username.sa.analyzed.0

  7. Daniel Craig Jallits
    Member
    Posted 6 years ago #

    Just browsed over to: http://mydomain/stats/resources/myusername.sa.analyzed.0 and it is recording. See below for the display

    Process CPU seconds user machine count average
    php5.cgi 7.3500 99.864% 0.031% 36 0.204
    sftp-server 0.0100 0.136% 0.000% 1 0.010
    ----------------------------------------------------------------------
    Total: 7.3600 100.000% 0.031% 37
    Average per day: 7.3600 1 days
    CPU percentage assumes 24000 cpu seconds per day total.

  8. bernabauer
    Member
    Posted 6 years ago #

    Jallits,

    Yours seems a hard problem to solve. The warning "You have to activate CPU monitoring. Check out how here." is only shown if the plugin can't find the CPU Usage file that should be in "/home/username/logs/resources" and it's name must be "username.sa.analized.0".

    I believe that this is a permission problem. The username informed to the plugin may not have read permission on the CPU usage file.

    One thing I know is that the username informed in the authentication page of http://mydomain/stats may NOT be the same username under which the blog runs.

    I have 3 WP blogs running under different usernames, but the username I use to authenticate to see the stats page is a different one. All the blogs have the plugins installed and working.

    Other than this permission problem, I really don't know why the plugin isn't working for you.

  9. Daniel Craig Jallits
    Member
    Posted 6 years ago #

    I obviously am using the correct username, as it is part of the naming convention of the following file.... "username.sa.analized.0"

  10. bernabauer
    Member
    Posted 6 years ago #

    Jallits, i contacted DH. You should open a ticket and point to this thread. They are going to help figure out the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic