WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Anyone familiar with Weaver II? Trying for custom headers for static pages. (6 posts)

  1. brainfreeze0
    Member
    Posted 2 years ago #

    I've spent so many hours already trying to implement this. I am using the Weaver II theme. I've tried several different plugins that have worked successfully for others to no avail integrating new coding into header.php to make it work. I have used the featured image with the image set to the exact specs as the current header I have as my default. All primary functions are enabled in my admin main menu section. No dice. The only thing I can think of is that I have the home page set as the home page in Appearance>>Reading and the 2nd page (my blog page) set as that. I had read somewhere you had to leave that blank (or "select") for it to allow customization.

    Nothing I have tried will work. I cannot post a link to it as I have been designing it on my local server (localhost) so its not actually live. This is driving me crazy. Any help would be greatly appreciated.

  2. WPyogi
    Volunteer Moderator
    Posted 2 years ago #

    Have you looked at the Weaver support pages?

  3. brainfreeze0
    Member
    Posted 2 years ago #

    Yeah thats where I got a lot of the ideas I tried that did not work. Also where I got someone talking about leaving the 2nd page blank (select) though not sure if that is for sure.

  4. scrambler
    Member
    Posted 2 years ago #

    To have all the options working on your blog page, you must not use the default wordpress one.
    Your blog page should be a static page using the "page with posts template" (or the default template and the [weaver_show_posts] shortcode), then in Settings > Reading, you home page should be set to a static page, and your Post page set to nothing (shows Select).

    Then all the options should work.

    Then when you want a custom header on any Weaver static page, you just need to select a featured image that has the size of the header.

    Feel free to seek more support in the weaver Forum
    http://forum.weavertheme.com/

    See this FAQ article:
    http://weavertheme.com/controlling-your-home-page/

  5. brainfreeze0
    Member
    Posted 2 years ago #

    Thanks, came to the same conclusion there a little earlier on their forums. Unfortunately once its been done theres no turning back as the -select- option disappears after you have selected one. Thanks

  6. scrambler
    Member
    Posted 2 years ago #

    That is not right.
    Normally you can absolutely change it back. I just did the test myself, I set "Post page" to one of my pages, saved it, then came back opened the "Post page" drop down list list again, and at the very top of the drop down list (you may have to scroll back up if the list is long), there is -select-, and you can select that line so that no pages are set as the WP Post page.

Topic Closed

This topic has been closed to new replies.

About this Topic