WordPress.org

Ready to get started?Download WordPress

Forums

Any Security Issues in 1.5.2? (13 posts)

  1. david67
    Member
    Posted 8 years ago #

    Hello,

    i have a little question about the 1.5.2 version of WordPress.

    Is it safe to continue working on it (cause i find it good enough for what i do) ??

    or is it needed to update to the latest version because of some possible security issues ?

    thanks a lot!

    David?

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    As far as known (and I have asked before and since the release of 2.x), 1.5.2 is all good.
    I am using 1.5.2 as are many many others.

  3. david67
    Member
    Posted 8 years ago #

    yes 1.5.2 is enough for what i do, i plan to update later, but this was to be sure :)

  4. bazil
    Member
    Posted 8 years ago #

    I am in the same boat, I like 1.5.2, since I am not all that savvy, I am sticking it out until I find all the plugins I want to work 100% with 2.x

    (my old theory, aint broke, dont fix it)

  5. vkaryl
    Member
    Posted 8 years ago #

    Makes a few of us, guys. I have a couple of 2.0+ installs, and they're okay, but the rest of my dozen or so stay on 1.5.2 for a LONG while yet.

    [Edited the topic title to actually reflect the fact that this is a question about issues, not reporting of same....]

  6. jfriesen
    Member
    Posted 8 years ago #

    You will probably want to upgrade to 1.5.3-beta1, an unofficial security release: http://wordpress.org/support/topic/66824
    JF ;)

  7. war59312
    Member
    Posted 7 years ago #

    bump!

    Does WP 1.5 suffer from the new security issue that was fixed in WP 2.0.4 ?

  8. whooami
    Member
    Posted 7 years ago #

    the registration one? no, because it didnt use a cache. Its (1.5) not safe otherwise though.

    How many exploits are you interested in reading about? I can find 2 easily in Google.

  9. I am sticking it out until I find all the plugins I want to work 100% with 2.x

    Well what plugins are you using? Like 99% of the plugins out there are compatible with WP2. ;)

    I mean, sure, 1.5.2 works, but I find the extra features of v2.x nice. :)

  10. OtherMichael
    Member
    Posted 7 years ago #

    >but I find the extra features of v2.x nice. :)

    yeah, like Ajax bloat.

  11. the registration one? no, because it didnt use a cache. Its (1.5) not safe otherwise though.

    Actually the cache issue with user registration was fixed in 2.0.3

    I believe the security issue that caused the release of 2.0.4 probably affects 1.5.2 (and the unofficial 1.5.3-beta)

  12. yeah, like Ajax bloat.

    How is it bloat? It only affects those couple management pages and it actually increases your efficiency as you don't have to reload the page.

    Don't get me wrong -- I'm not arguing for or against it, I'm just saying things like that are hardly a reason not to use it IMO.

  13. war59312
    Member
    Posted 7 years ago #

    Well one is an easy fix:

    http://trac.wordpress.org/changeset/3440

    Another easy fix:

    http://www.securityfocus.com/archive/1/426304/30/60/threaded

    Those the two you mentioned?

Topic Closed

This topic has been closed to new replies.

About this Topic