WordPress.org

Ready to get started?Download WordPress

Forums

Any ideas on how to grant access to a category to only specific users? (8 posts)

  1. scottmcdanielorg
    Member
    Posted 8 years ago #

    I'm setting up WP for use as an employee blog/intranet (in lieu of emailing everything to the entire group), and one of my 'wants' is for management to be able to select 'Important' (or some derivative) as a category. Then I can use c2c_get_recent_posts and filter these iimportant posts into an announcememnt box I've placed in index.php, before the loop.

    The theory is that this will allow 'important' messages to rise above the normal, mundane stuff like softball scores or birthday posts.

    Any ideas on how to grant access to a category to only specific users?

  2. moshu
    Member
    Posted 8 years ago #

    Access - as for reading or writing?

  3. jwurster
    Member
    Posted 8 years ago #

    There is the Category Access plugin.

  4. joshziman
    Member
    Posted 8 years ago #

    Category Access
    I think something similar to this should be automatically on WordPress.

  5. scottmcdanielorg
    Member
    Posted 8 years ago #

    Sorry folks, was ill and didn't get back to check for answers!

    Access - to post using that category.

    Checking out that plugin, thanks for the linkage.

  6. moshu
    Member
    Posted 8 years ago #

    For access restriction when writing/posting:
    see Limit Categories in http://codex.wordpress.org/Plugins/Restriction

  7. scottmcdanielorg
    Member
    Posted 8 years ago #

    Ah, RedAlt. Such a blessing to us all.
    :)

    Thanks Moshu.

  8. manstraw
    Member
    Posted 8 years ago #

    Just thought I would mention that Category Access also restricts posting. You see the category in your list, but attempting to post to it will (without warning or any other indication), switch the post to draft and change the category to the default.

    Also note that I was getting an error running 0.5.1 of Category Access, and went back to 0.5.0, which worked fine under wp 2.0.3. I emailed the author, but haven't heard if he's addressed the error yet.

Topic Closed

This topic has been closed to new replies.

About this Topic