WordPress.org

Ready to get started?Download WordPress

Forums

Another user with plugin upgrade woes since 2.6 (5 posts)

  1. speerga
    Member
    Posted 5 years ago #

    I see several people posting here about problems trying to get the automatic plugin upgrade to work in 2.6.

    I'm having problems with every plugin I try to automatically update. In each case (I've done it with four or five different plugins), there have been error messages that the plugin could not be unpacked. Or, in some cases, the plugin is unpacked, then the screen says "Update completed" -- but it isn't.

    Anyone fixing this annoying bug??

  2. mrmist
    Forum Janitor
    Posted 5 years ago #

    I think that the automatic plugin updater is really still in its early stages. I have a couple of identically configured WP blogs, on different hosts, one host will upgrade plugins just fine, the other has issues with directories. I can't really blame WordPress for that, because how can they know the particular quirks of evrey single different Apache configuration?

    So I treat it as a bonus. If the auto-update doesn't work, it's no big deal, I do the update manually.

  3. speerga
    Member
    Posted 5 years ago #

    Yeah, since I posted the above opening post, I discovered one of my sites that does the auto plugin update function perfectly, and three or four which give the error and mess up problems I mentioned.

    I'm not bright enough to figure it out. Sure was nice on 2.5, though, because it always worked on all my sites. Got spoiled.

    But since it did, indeed, work on all my 2.5 blogs, I really can't see why they can't get it to work that way on 2.6 or 2.6.1?

  4. stuzog
    Member
    Posted 4 years ago #

    I'm experiencing plugin upgrade failures with WP 2.8 and the following error:

    Downloading update from http://downloads.wordpress.org/plugin/wp-email.2.50.zip.
    Unpacking the update.
    Installing the latest version.
    Deactivating the plugin.

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /Applications/XAMPP/xamppfiles/htdocs/loversoflife/wp-admin/includes/class-wp-upgrader.php on line 180
    Incompatible Archive

    Plugin upgrade Failed.
    Actions: Return to Plugins page

    There is no file class-wp-upgrader.php in WP 2.8

  5. aneuryzma
    Member
    Posted 4 years ago #

    same problem here, did you solve it ?
    the file class-wp-upgrader.php exists in wp 2.8 by the way.
    thanks

Topic Closed

This topic has been closed to new replies.

About this Topic