WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Another - Style.css not updating (7 posts)

  1. hitchy.ali
    Member
    Posted 1 year ago #

    Hi Guys,

    I know there have been a number of previous posts about the style.css not updating on the websites when updated over FTP.

    I have the problem on 3 different browsers (Chrome, FF & IE).

    I have tried CTRL + F5 and SHIFT + F5 to get the browsers to recognise the updated code but to no avail.

    I honestly have no idea why this is happening and any help would be much appreciated.

    The site in question is http://www.silverfernfitness.co.uk.

    The @font-face url should be changing to the following, but so far without any luck:

    @font-face {
        font-family: "MgOpenModata";
    	src: url('/fonts/fontface/mgopenmodataregular-webfont.eot'); /* IE9 Compat Modes */
        src: url('/fonts/fontface/mgopenmodataregular-webfont.eot?#iefix') format('embedded-opentype'), /* IE6-IE8 */
    	     url('/fonts/fontface/mgopenmodataregular-webfont.woff') format('woff'), /* Modern Browsers */
    	     url('/fonts/fontface/mgopenmodataregular-webfont.ttf')  format('truetype'), /* Safari, Android, iOS */
    	     url('/fonts/fontface/mgopenmodataregular-webfont.svg#svgFontName') format('svg'); /* Legacy iOS */
    }

    Sod's law it will show up fine on your screens, but I can't continue to edit the site if it doesn't update on mine. Help!

    Thanks,
    Ali

  2. hitchy.ali
    Member
    Posted 1 year ago #

    Having looked at the site again, it appears that .social-follow is also not updating. The code should be as follows:

    .social-follow {
    	width: 281px;
    	height: 102px;
    	float: left;
    	margin-left: 498px;
    }

    BUT is still

    .social-follow {
    width: 281px;
    height: 102px;
    float: left;
    margin-left: 520px;
    }

    Again, no idea why the code is not updating.

    Thanks,
    Ali

  3. Andrew
    Forum Moderator
    Posted 1 year ago #

    Have you cleared your cache manually (through browser settings)?
    Some ctrl and f5 shortcuts are deprecated.

    Whereabouts are you adding your styles?

  4. hitchy.ali
    Member
    Posted 1 year ago #

    I have cleared the cache and weirdly the problem is still there.

    I am adding the styles to style.css.

    http://www.silverfernfitness.co.uk/wp-content/themes/sf_fitness/style.css

  5. Andrew
    Forum Moderator
    Posted 1 year ago #

    Try adding styles through a Custom CSS plugin.

  6. hitchy.ali
    Member
    Posted 1 year ago #

    Problem found. My hosting is with iPage and 'We use Varnish Caching technology'. This essentially means that their websites take a bit of time to update any changes so I needed to add a bit of code to the ht.access file.

    SOLVED

  7. todaydownloadz
    Member
    Posted 10 months ago #

    can i know how you solve that issue? I mean did you have to change htaccess file ? if so can i know how to do it

    i am facing the same problem..

    any help would be appriciated.

    Thank You

Topic Closed

This topic has been closed to new replies.

About this Topic