WordPress.org

Ready to get started?Download WordPress

Forums

Another request for "Error: PHP is not running" help (2 posts)

  1. sbailey14
    Member
    Posted 9 months ago #

    "Error: PHP is not running" keeps frustrating me but PHP is running beautifully, I use phpMyAdmin with MySQL on localhost every day. I’ve searched the history of discussions of the “PHP is not running” problem here but most get “resolved” without explaining “how.”

    I'm trying to install WordPress 3.61 on my own computer that has Windows 7, Apache 2.2.22, MySQL 5.6.12, phpMyAdmin 4.0.6, PHP 5.3.5 (which works beautifully with other programs like MySQL). In Windows \ Properties \ Security I have complete permission to WP and to all else. WP is also completely "trusted" in my Kaspersky antivirus.

    Apparently the name “WAMP Server” is lately used for a precanned package I never heard of, despite “WAMP server” already having been a term in general use many years not referring to some canned package. So now because of that naming confusion most WP installation instructions I find for Apache on Windows say to put WP into www, a folder unique to that canned wampserver. Well my “REAL” (j/k) WAMP server doesn’t have that. Tried making a www container for WP at the level of C:\Program Files (x86)\Apache Software Foundation\Apache2.2\ and also a level deeper, in \htdocs. Neither works. So now WordPress-3.6.1 is in the localhost web server, or in other words is sitting in C:\Program Files (x86)\Apache Software Foundation\Apache2.2\htdocs\wordpress.

    Based on WordPress forum posts and other instructions on the web, I’ve tried (many times):

      changed localhost to '127.0.0.1' in wp-config.php. Also tried 127.0.0.1 (without the single quotes)

      using browser address localhost/wordpress/wp-admin/install.php but that returns a firefox browser screen that’s all blank white.

      navigating the browser to install.php , which equals this browser address file:///C:/Program%20Files%20%28x86%29/Apache%20Software%20Foundation/Apache2.2/htdocs/wordpress/wp-admin/install.php then gives “Error: PHP is not running.”

      manually editing wp-config.php per instructions on the WordPress 5 min setup still produces "Error: PHP is not running."

      flushing DNS 3 times and toggling Apache server off - on and clearing browser cache and clearing browser history between each trial didn’t help.

    On this page a guy says, “I had to edit its Preferences and change the "Start Page URL" to "/" instead of "/MAMP/" for it to stop giving me that error.” Well what does he mean by “it’s Preferences?” Does “its” mean WP? Apache? PHP? WHERE do you make that change? I don’t find the command he calls “Start Page URL” in httpd.conf or php.ini or wp-config.php. Guys in other forum threads say they fixed this themselves, but not how, or thank someone for the answer via IRC but don’t tell what it was.

    This guy’s instructions are real clear & simple, no joy.

    What else can I try to get past, "Error: PHP is not running"?

  2. Pipe Ten Hosting
    Member
    Posted 9 months ago #

    Hi,

    What happens if you visit "localhost" in your browser?

    Could you also create a phpinfo page, visit it and see if it displays properly?

    Kind regards
    Jamie

Reply

You must log in to post.

About this Topic