WordPress.org

Ready to get started?Download WordPress

Forums

Another "long post won't save" issue (23 posts)

  1. blueamulet
    Member
    Posted 4 years ago #

    This is something I've been dealing with for a couple days now. I can't save any posts that are maybe 4 or 5 thousand words in length. And yet, I can easily post a very quick 'test message' of just a few keystrokes. Something fishy in Denmark!

    I didn't find anything worthy of note in my error log...just a couple things that had to do with a theme that was causing a problem.

    NOW I'm beginning to wonder if my current trouble might be due to posts that are "too long"?

    Found advice about the "wp_settings.php" file. This is supposed to help:

    if ( !defined('WP_MEMORY_LIMIT') )
    define('WP_MEMORY_LIMIT', '48M');

    I see the file in my FTP, but how do I open files like these? Each time I've tried, I get a nag screen about PhotoParade which I don't have. Could I just download the .php file to my own drive and view it from there, fix it, then upload it back to the other server? I never use PHP files so I'm not sure!

  2. wprelief
    Member
    Posted 4 years ago #

    Yes, you want to download the file to your computer. Make a copy, just in case. Then open the original with a text editor and make the change and re-upload (replace the file on the server).

    The backup is the most important step, in case something goes wrong you have something to roll back to.

  3. blueamulet
    Member
    Posted 4 years ago #

    Okay, I did that and it really was easy to find the means to open the file via a text editor. So, at least now I know how to do that! ;)

    And I'll be sure to have a backup too.

    It's certainly a very long file, but I should be able to succesfully tweak it and then, cross my fingers in hopes that the tweak will fix the issue. Seems funny that any other small drafts do save just fine.

    Will let everyone know what the outcome is...just in case another user runs into the same problem. :)

  4. You *don't* want to edit core WP files. You will loose the changes once you upgrade.

    Increase memory for php by putting this near the top of wp-config.php

    define('WP_MEMORY_LIMIT', '64M');

    and see this post: http://wordpress.org/support/topic/320207?replies=3

  5. blueamulet
    Member
    Posted 4 years ago #

    AHA! Thanks, SDT. All righty. Let's try this approach.

    I did change the wp_settings file, and yes I do have a backup of the original file. The only change was the number, I just carefully altered the '32' to '48'. I should be able to fix it back again w/o any worries. I will do so, since the change didn't do a thing to help the issue. I can still easily save 'test messages' but nothing lengthy.

    Umm...OK...I have the file open in notepad. But where, exactly, should I paste the two changes- I'm willing to try both! So anxious to make my dot Org blogsite a success.

    define('WP_MEMORY_LIMIT', '64M');

    AND-

    ini_set('pcre.backtrack_limit', 1000000);

  6. Like this:

    <?php
    
    define('WP_MEMORY_LIMIT', '64M');
    ini_set('pcre.backtrack_limit', 1000000);
    
    /**
     * The base configurations of the WordPress.
  7. wprelief
    Member
    Posted 4 years ago #

    Someone in another slug suggested the memory-bump plugin http://wordpress.org/extend/plugins/memory-bump/

  8. @wprelief: wp-config.php is not a core WP file and it's OK to edit it.

  9. blueamulet
    Member
    Posted 4 years ago #

    ARGH! I pasted in the tags but when I go to save the file, all the formatting disappears. Why is it doing that? Would it still function even with the formatting gone?

    OK, I pasted it here to show what I mean. Now it's partly formatted but still looks strange. Will that matter?

    [Large code excerpt remove by moderator. Per forum rules, please post all large code excerpts in the pastebin, and censor your database login details this time.]

  10. Are you using a plain text editor to edit the file?

  11. wprelief
    Member
    Posted 4 years ago #

    Since wp-settings has the check to see if WP_MEMORY_LIMIT is defined, you could in fact just drop the suggested code above into your wp-config.php file.

  12. blueamulet
    Member
    Posted 4 years ago #

    Sorries about not using 'pastebin,' I forgot!! ;-)

    MacManX, yep, I've been using Notepad to edit the file. Tried it with NotePad++ and an oldie but a goodie, NoteTabLight. Still same results, formatting gone. Weird that it would *partly* come back when I pasted the contents in a post here. Is there another means of keeping formatting while tinkering with a file?

    Saw the plain text editors link...it includes Notepad++. I presume there is a 'special' means of editing php files there without messing up as I've done, lol

    wprelief, how would I do that, plz? --'just drop the suggested code above into your wp-config.php file.' I thought that was what I was doing, at least on the latest attempt before ftp'ing back.

    Last nite I did replace the file thru ftp. AND got a fatal error! EEeepp. Something to do with 'line 15,' not sure what that's about.

    Was hoping the original "try" in the wp_settings file would do the job. It was really easy tweaking that one. But 'config,' not so easy!

    OK, tried fixing 'config' with Notepad++ and apparently the formatting did not change. Uploaded to my subdomain. Tried logging in. Got the same fatal-error msg only this time it's for Line 1. Here it is:

    Fatal error: Call to undefined function phpdefine() in /home/seaymee/public_html/aeolusia/wordpress/wp-config.php on line 1

    I thought we couldn't "break" WP...it looks like I did! -lol

  13. You've got something wrong in wp-config.php. Did you delete the starting <?php at the top of the file? Or the semicolon at the end of

    define('WP_MEMORY_LIMIT', '64M');

  14. blueamulet
    Member
    Posted 4 years ago #

    OH...no, I didn't. I thought the starting characters were meant to stay in there. Thought the semicolon was also 'supposed' to be there too. So should I be deleting those or not?

    Most of my online probs are basically simple blunders. This should be, too, if I can tweak things JUST right...

    I could attach the current version of the file here, if that would clarify matters.

    ASAP

  15. No, the characters stay there. Paste your wp-config.php in WordPress Pastebin and delete your password and login out of it and then link pastebin here.

  16. blueamulet
    Member
    Posted 4 years ago #

    I didn't see anything that needed removal, and it did post me as "Anonymous," so I guess I'm safe...!

    Here 'tis... Somehow it don't look "right" to me, so much double spacing. But this is straight from Notepad++. Now it has enumerated lines, something it didn't have in my editor.

    http://wordpress.pastebin.com/JqdagaDL

    Oh and I put back the original php file stored in Downloads. The edited copy was saved somewhere else. And now, my WP is working again...except for this one huge problem! =(

  17. You did post your DB passwords, so now you're going to have to change them or risk being hacked.

    Try the revised code in wp-config.php. Be sure there is no white space at the top of the file.

  18. blueamulet
    Member
    Posted 4 years ago #

    I saw only "Anonymous" on my Pastebin effort, so you are referring to my WordPress ID and PW?

    I saved the revision in ordinary Notepad again, I hope that won't cause the same problem I had before...!

    AWW MAN. I did manage to get logged in again. But, the original problem still isn't resolved. What we did with the config file hasn't helped. I'm still getting those 500 and 404 Error files.

    I did warn my friend who owns the domain, about the possible hacking danger. I hope she will take heed!!! She is really in harm's way much more than I am.

  19. wprelief
    Member
    Posted 4 years ago #

    I am wondering if you could try something else for me, since you have the change in your wp-config file completed.

    Can you please take a list of all your plugins that are activated, then disable ALL plugins.

    See if your 404 or 500 errors comes back. If they are gone, one or more of your plugins is causing the issue you are reporting. If not, then you may need some more hands on help with this issue.

  20. blueamulet
    Member
    Posted 4 years ago #

    Well, since i only had ONE plugin added (wise, huh??), that being the admin-bar plug, it took only a few moments to disable it.

    And, as I recall, it didn't help! Last night I decided to try a last-ditch effort and just delete the entire program, all folders, etc. off my subdomain. Did that and tried logging back in, got the message about the lack of a wp-config file. Been working with that, I've probably got it ready now. I'm about to upload it to my subdomain and we'll see what happens! *drum roll*

    NOPE...I still can't login even with the config file uploaded. Now I get this:

    Parse error: syntax error, unexpected $end in /home/seaymee/public_html/aeolusia/wordpress/wp-includes/post.php on line 4629

  21. wprelief
    Member
    Posted 3 years ago #

    It looks to me like there is a syntax error in the config file now that there is a change. This may violate the TOS of this forum, but you can contact me at matt at spottedkoi.com and I will help you out with this syntax problem.

  22. esmi
    Forum Moderator
    Posted 3 years ago #

    Providing no one is actively soliciting paid work via the forum, there's no breach of any TOS. :-)

  23. blueamulet
    Member
    Posted 3 years ago #

    Matt and Esmi, no worries about ToS, mine is just a hobby site, no money being made or exchanged :)

    And, geez I almost forgot *looks back via Filezilla at Quickconnect urls*...yep, my WP on the host I (stupidly) show the name of above, has been deleted. I really felt like the best thing was to give up.

    HOWEVER...another pal who provided me some space last winter for WP got back to me and has now given me the whole domain, whoooo!! Feels like Christmas or my BD. WP was gone from there, I guess he removed it thinking I wasn't going to use it. It just took me awhile to learn how and to get going... But I did, finally. And I reinstalled it at his webspace.

    So, now, I don't have that particular error msg anymore, I can login. But I have what shows on a different thread here, a big problem pertaining to the "simplepie.php" file. "Simple as pie"? HAH. ':-\

    Will find link to thread, and post url here.

    This is it:

    http://wordpress.org/support/topic/back-to-wporg-but-a-new-and-strange-error-msg?replies=3

Topic Closed

This topic has been closed to new replies.

About this Topic