WordPress.org

Ready to get started?Download WordPress

Forums

Another Go Daddy installation problem (12 posts)

  1. pushkin
    Member
    Posted 2 years ago #

    Trying to get my site, currently on local host, onto external Go Daddy host. After I follow instructions for transferring WP site, this is what I end up with. No styling or anything, while clicking on links/posts on page goes to local host. What am I doing wrong here, and what should I do to fix it?

    Thanks

  2. govpatel
    Member
    Posted 2 years ago #

    did you change the urls in Settings>>>General and database info wp-config.php.
    Note Godaddy does not use localhost

  3. pushkin
    Member
    Posted 2 years ago #

    Thanks for getting back.

    I can't find Settings>>>General; and regarding the wp-config.php file, this is how it currently reads. Other than the salt keys, I didn't change anything in it because it seemed all correct to me (I've xxxxx the password). Does this file seem correct to you?

    <?php
    /**
    * The base configurations of the WordPress.
    *
    * This file has the following configurations: MySQL settings, Table Prefix,
    * Secret Keys, WordPress Language, and ABSPATH. You can find more information
    * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
    * wp-config.php} Codex page. You can get the MySQL settings from your web host.
    *
    * This file is used by the wp-config.php creation script during the
    * installation. You don't have to use the web site, you can just copy this file
    * to "wp-config.php" and fill in the values.
    *
    * @package WordPress
    */

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'gol1209105211889');

    /** MySQL database username */
    define('DB_USER', 'gol1209105211889');

    /** MySQL database password */
    define('DB_PASSWORD', 'xxxxxxxxx');

    /** MySQL hostname */
    define('DB_HOST', 'gol1209105211889.db.9159303.hostedresource.com');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

  4. Xperic
    Member
    Posted 2 years ago #

    Change the value in the MySQL database. You can use PHPMyAdmin for that.

  5. pushkin
    Member
    Posted 2 years ago #

    I've managed to go into the database via Manage via phpMyAdmin and changed the URL showing as 'local host' to the name of my website. The site now has some styling, but the header is missing and clicking on links still refers back to local host. Here's the site now.

    I've also managed to find Settings>>>General as suggested by govpatel – I presume you meant for the WordPress installation, and this is what it says:

    Successfully Installed on golovegreece.com
    (March 31, 2012)
    URL: GOLOVEGREECE.COM/
    Admin URL: GOLOVEGREECE.COM/wp-admin/
    FTP path: /
    Database name: gol1209105211889 (golovegreece@WordPress)
    Hosting account: Visit Hosting Center
    Server technologies: LINUX, PHP 5.1, CGI 2.0, PERL 5.0, PYTHON 2.4, RUBY 1.8.4, MYSQL 4.1, 5.0

    Is that right? Should I change anything here? If yes, how? What else do I need to do?

    Your help is greatly appreciated. Thanks.

  6. govpatel
    Member
    Posted 2 years ago #

    In Settings>>>General you should have your urls if installed in root

  7. pushkin
    Member
    Posted 2 years ago #

    you should have your urls if installed in root

    I don't quite get this. Can you explain a little further. Thanks

  8. Xperic
    Member
    Posted 2 years ago #

    In the WordPress dashboard, go to Settings->General and change the URL(s) in the fields.

  9. pushkin
    Member
    Posted 2 years ago #

    Sorry, I'm new to this and don't understand what I have to do.

    Thanks to Xperic I've now found the fields govpatel was talking about – in WordPress Dashboard, not in the part of Go Daddy that refers to WordPress installation.

    It says:

    WordPress Address (URL): http://golovegreece.com

    Site Address (URL): http//localhost

    So, what do I have to change these to?

    I've looked up the WordPress <a href="http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory
    ">help file and it says:

    3. In the box for WordPress address (URL): change the address to the new location of your main WordPress core files. Example: http://example.com/wordpress
    4. In the box for Site address (URL): change the address to the root directory's URL. Example: http://example.com

    But I have no idea what the address of my WordPress core files is; nor do I know what the URL of the root directory is. How can I find these out? Thanks

  10. govpatel
    Member
    Posted 2 years ago #

    Site address needs to be http://golovegreece.com since you http://localhost it takes you to localhost as urls when you click on any link

  11. pushkin
    Member
    Posted 2 years ago #

    I'm now no longer able to get into wp-admin and the WordPress Dashboard on my externally hosted site. I can access my site – which is now showing its header – but adding wp-admin to the URL takes me to localhost. I can access the Dashboard in local host. Any suggestions? Thanks

  12. pushkin
    Member
    Posted 2 years ago #

    I'm now back into the WordPress Dashboard, having noticed that the values in phpmyadmin in Go Daddy had reverted to local host. However, having gone back into Settings>>General in the WP Dashboard and changed the values of

    WordPress Address (URL): http://golovegreece.com

    Site Address (URL): http//localhost

    so that they both read: http://golovegreece.com, I've still got the problem of clicking on links that refer to local host!

    Help!
    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic