WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Another admin-side white screen of death post (23 posts)

  1. frikafrax
    Member
    Posted 2 years ago #

    Yes, another "white screen of death" problem and I'm at the end of my rope. :-(

    The front end of the blog loads fine but the administration side doesn't. No dashboard, and all attempts to access any scripts inside /wp-admin/ results in a blank screen.

    What I've tried with no results:

    • Disabled all plugins, deleted all unused/inactive plugins.
    • Disabled custom theme but WordPress fails to fall back to TwentyEleven (white screen all around).
    • Checked for extra blank lines in wp-config.php, functions.php et al.
    • Re-uploaded WordPress v3.3.2 from a newly downloaded installation
      archive.
    • Rolled back to v3.3.1 from a newly downloaded installation archive.
    • Checked/increased WordPress and PHP memory limits.
    • Checked/repaired database via myphpadmin.
    • Restored database from earlier backups.

    At this point, I'm open to any and all suggestions. I'll even sacrifice a chicken if I have to. :-P

    Thanks!

  2. govpatel
    Member
    Posted 2 years ago #

    Disabled custom theme but WordPress fails to fall back to TwentyEleven (white screen all around).

    Try and change the theme manually in database wp_options to twenty eleven theme

  3. frikafrax
    Member
    Posted 2 years ago #

    Manually editing wp_options to change themes unfortunately didn't fix the missing dashboard problem.

  4. govpatel
    Member
    Posted 2 years ago #

    So you have twentyeleven theme activated post your url to see what we get.

  5. frikafrax
    Member
    Posted 2 years ago #

    I've switched two three different themes via manual editing of wp_options and the blog shows up fine on the public end each time, but the Dashboard always fails to load. It's always blank and 0-bytes.

    Here's the blog.

  6. govpatel
    Member
    Posted 2 years ago #

    I get blank page as well did you try and replace wp-admin folder there must be a corrupted file in the folder

  7. govpatel
    Member
    Posted 2 years ago #

    I tried login page from here
    http://neb.frikafrax.com/wp-login.php and seems as if you missing the file in root can you check if you have wp-login.php file in root

  8. frikafrax
    Member
    Posted 2 years ago #

    That's odd that you're getting a blank page. The blog displays correctly for me under Chrome, IE and Firefox, even after flushing their caches and reloading the blog.

    I've re-uploaded and overwrote all the core WordPress files a number of times from a newly downloaded WordPress installation archive so I'm fairly certain that I have no missing or corrupt files.

    I'm re-uploading the core WordPress files again right now, just to be certain.

    EDIT: In addition, I'm getting the WordPress log-in page when I access wp-login.php directly.

  9. govpatel
    Member
    Posted 2 years ago #

    That's odd that you're getting a blank page. The blog displays correctly for me under Chrome, IE and Firefox, even after flushing their caches and reloading the blog.

    I am getting the same blank page on log in page not your website

    The only way to find out what file is causing the problem is to see error log on your server.

  10. frikafrax
    Member
    Posted 2 years ago #

    Can you try accessing the blog one more time to see if you're still getting a blank page?

  11. govpatel
    Member
    Posted 2 years ago #

    I am still getting blank page on http://neb.frikafrax.com/wp-admin

    The site opens fine

    Did you deactivate all plugins by
    try manually resetting your plugins, using ftp rename plugins folder to plugins_hold and create a blank plugins folder If that resolves the issue, delete blank plugins folder and rename original back to plugins reactivate each one individually until you find the cause.

    Did you check error log on server to see what file is causing the problem

  12. Paul
    Member
    Posted 2 years ago #

    I have had this same issue all day and have just managed to get logged in to my dashboard.

    In the phpMyAdmin wp-options table I changed these three fields back to 'twentyeleven'

    template (on page 2 with 30 records per page)
    stylesheet (on page 2 with 30 records per page)
    current_theme (on page 4 with 30 records per page)

    Not sure if all three needed changing but did them all anyway.

    My issue and probably yours too is clearly with the theme. Gonna go ahead and try to correct things now and will report back on how I get on.

    Regards, Paul

  13. frikafrax
    Member
    Posted 2 years ago #

    @govpatel

    Yes, I've tried deactivating all my plugins using both the plugin directory renaming technique as well as editing the wp_options -> active_plugins field in the database but with no luck.

    Usually disabling the plugins has worked for me in the past when I've gotten white screens but not this time.

    @Paul

    I've already tried switching themes by manually editing the database with no result. The public end of the blog switches themes just fine but the Dashboard still won't load regardless of which themes I switch to.

    I don't think it's a hosting issue since I have three other WordPress installations on the same host. Their plugin compliment is even roughly the same as the problematic blog's and yet they're working properly.

  14. govpatel
    Member
    Posted 2 years ago #

    The only way to see what is causing the problem is to see error log try this

    First check wp-config.php if you have any blank space before
    line 1

    <?php

    code
    if there is none then try and add this code in next line

    error_reporting(E_ALL); ini_set('display_errors', 1);

    In addition, add the following code above
    /* That’s all, stop editing! Happy blogging. */ :

    define( 'WP_DEBUG', true);

    See what error you get.

  15. frikafrax
    Member
    Posted 2 years ago #

    @govpatel

    I've checked for extra blank lines and trailing spaces in wp-config.php (functions.php too) and there are none.

    Here's the debug listing:

    Notice: Undefined index: HTTPS in /home/myblog/public_html/neb/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 526
    
    Notice: Undefined index: HTTP_X_FORWARDED_PROTO in /home/myblog/public_html/neb/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 526
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/myblog/public_html/neb/wp-config.php:1) in /home/myblog/public_html/neb/wp-content/plugins/bad-behavior/bad-behavior/screener.inc.php on line 9
    
    Notice: get_settings is deprecated since version 2.1! Use get_option() instead. in /home/myblog/public_html/neb/wp-includes/functions.php on line 3467
    
    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/myblog/public_html/neb/wp-includes/functions.php on line 3587
    
    Notice: Undefined property: s2_frontend::$s2_mu in /home/myblog/public_html/neb/wp-content/plugins/subscribe2/classes/class-s2-core.php on line 13
    
    Notice: Undefined variable: post_title in /home/myblog/public_html/neb/wp-content/plugins/wordpress-ping-optimizer/cbnet-ping-optimizer.php on line 78
    
    Notice: Undefined variable: post_type in /home/myblog/public_html/neb/wp-content/plugins/wordpress-ping-optimizer/cbnet-ping-optimizer.php on line 78
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/myblog/public_html/neb/wp-config.php:1) in /home/myblog/public_html/neb/wp-content/plugins/wp-mobile-detector/functions.php on line 690
    
    Notice: Use of undefined constant wprp_init - assumed 'wprp_init' in /home/myblog/public_html/neb/wp-content/plugins/wp-reportpost/main.php on line 15
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/myblog/public_html/neb/wp-config.php:1) in /home/myblog/public_html/neb/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 76
    
    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/myblog/public_html/neb/wp-includes/functions.php on line 3467
    
    Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home/myblog/public_html/neb/wp-includes/functions.php on line 3467
    
    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/myblog/public_html/neb/wp-includes/functions.php on line 3551
    
    Notice: wp_register_style was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/myblog/public_html/neb/wp-includes/functions.php on line 3587
    
    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/myblog/public_html/neb/wp-config.php:1) in /home/myblog/public_html/neb/wp-content/plugins/si-contact-form/si-contact-form.php on line 2189
    
    Notice: Use of undefined constant wprp_head - assumed 'wprp_head' in /home/myblog/public_html/neb/wp-content/plugins/wp-reportpost/main.php on line 63

    I gone through the debug log and disabled every plugin that was reporting an error of some kind.

    I also made sure that when disabling SuperCache, I removed its entries from .htaccess.

    Unfortunately, still no Dashboard.

  16. govpatel
    Member
    Posted 2 years ago #

    Looks like you have quite few problems and you say that have replaced all files and folder except wp-content folder.

    Did you upgrade this install or is this fresh install.

    I am checking errors.

  17. govpatel
    Member
    Posted 2 years ago #

    deactivate all plugins and leave them deactivated and then see what error you get on the page.

    I see you have wp-super-cache disable that as well

  18. frikafrax
    Member
    Posted 2 years ago #

    Yes, I've replaced all the WordPress core files, including the wp-content folder, so the TwentyEleven theme and the Akismet plugin on the server were overwritten with fresh versions from the installation archive.

    The blog was recently upgraded from WordPress v3.3.1 to WordPress v3.3.2. After the upgrade, the blog was working fine until last night when it just stopped working. I hadn't made any changes to the blog since it was last fully functional.

    Currently, all the plugins are disabled (renamed plugins directory) and I've set the active_plugins field in the database to a:0:{} to be certain.

    No luck. Dashboard is still a white screen.

  19. frikafrax
    Member
    Posted 2 years ago #

    @govpatel

    Sorry, misunderstood what you were asking in your previous post.

    Here's the debug errors with all plugins disabled, TwentyEleven theme installed, and when I load the home page:

    Warning: include_once(/home/myblog/public_html/neb/wp-content/plugins/wp-super-cache/wp-cache-phase1.php) [function.include-once]: failed to open stream: No such file or directory in /home/myblog/public_html/neb/wp-content/advanced-cache.php on line 8
    
    Warning: include_once() [function.include]: Failed opening '/home/myblog/public_html/neb/wp-content/plugins/wp-super-cache/wp-cache-phase1.php' for inclusion (include_path='.:/usr/lib/php') in /home/myblog/public_html/neb/wp-content/advanced-cache.php on line 8

    This is the debug errors I get when I try to load to go to /wp-admin/:

    Warning: include_once(/home/myblog/public_html/neb/wp-content/plugins/wp-super-cache/wp-cache-phase1.php) [function.include-once]: failed to open stream: No such file or directory in /home/myblog/public_html/neb/wp-content/advanced-cache.php on line 8
    
    Warning: include_once() [function.include]: Failed opening '/home/myblog/public_html/neb/wp-content/plugins/wp-super-cache/wp-cache-phase1.php' for inclusion (include_path='.:/usr/lib/php') in /home/myblog/public_html/neb/wp-content/advanced-cache.php on line 8
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/myblog/public_html/neb/wp-config.php:1) in /home/myblog/public_html/neb/wp-includes/pluggable.php on line 866
  20. Paul
    Member
    Posted 2 years ago #

    I have managed to fix my white screen issue. ( big thanks to Jan )

    My issue, an looking at your error bug your possibly too, was my themes function.php.

    I made a backup of the function.php file just in case. Then I saved the original function.php from my original theme download over the existing one on the server.

    In my case I had to rewrite some excludes back to the file to hide some pages from my menu but that was it.

    All is now back to normal. I hope this helps.

    Regards, Paul

  21. govpatel
    Member
    Posted 2 years ago #

    @frikafrax sorry for delay as I was busy today I just got back if you look the errors on /wp-admin/

    With all plugins deactivated you still have error on wp-super-cache so delete that folder altogether in plugins folder

    You have this file in wp-content folder advanced-cache.php delete that one as well and see if that solves the problem.

    If you still have problem I would recommend that you backup your database and reinstall from scratch in a new folder and once you have one installed change the database settings in wp-config.php new install to your old database and see if you have problems in this install to rule any problems in database.

    If all goes well you rename wp-content folder in new install and copy wp-content folder from your old install to new install and see if this solves your problem.

  22. frikafrax
    Member
    Posted 2 years ago #

    @govpatel

    Thanks very much for your help. It's greatly appreciated.

    Deleting Super Cache and advanced-cache.php had no effect but the site's back up and running properly again!

    What I did was I re-installed WordPress completely from scratch into an empty directory, confirmed Dashboard was working, imported the original database and copied the plugins directory over.

    Before doing anything in WordPress, I edited the database via phpmyadmin to manually de-activate all the plugins by setting wp_options -> active_plugins to "a:0:{}". I also re-saved my permalinks settings.

    I copied over the wp-content/uploads directory, then re-enabled plugins incrementally until the site seemed to be displaying and operating normally.

    The odd thing was that when I first attempted a fresh re-installation of WordPress using an empty database and installation directory and no plugins copied over, I was surprised to see "headers already sent" error messages and a blank dashboard. But I met with success on the second re-installation attempt. Not sure what happened there...

    I'm not sure what the cause of the Dashboard failure was since it wasn't any of the "usual suspects." I.e. theme, plugins, extra blank lines or white space or corrupt core files etc.

    But at least things are working now.

  23. govpatel
    Member
    Posted 2 years ago #

    Glad to know that you have your website normal we tried all we know could cause the problem and that why I recommended to install from scratch

Topic Closed

This topic has been closed to new replies.

About this Topic