WordPress.org

Ready to get started?Download WordPress

Forums

Annoying 'Auto Save' Page Jumps. (20 posts)

  1. axellediagram
    Member
    Posted 5 years ago #

    When I'm updating a blog or a page within the WordPress admin, the page frequently 'autosaves', AKA saves a 'draft'. This, of course, is a handy freature, but at the same time, it's become a highly annoying problem.

    Every time the page/post I'm working on autosaves, the post box jumps from wherever my blinking cursor is up, about five to ten lines above ... Almost as if someone was hitting the 'Page Up' key on my keyboard.

    It's extremely annoying as I constantly lose my place on the page, and it's come to the point where I have to type out an entire post in Notepad beforehand, and then paste it into the post box.

    Does anyone else have this problem? Is it going to be fixed in the next version of WP? Any help would be appreciated. :)

    OS: Windows Vista Home Basic.
    Browser: Internet Explorer 8. (Please, no advice to use a different browser, thank you. I have the most recent version of FireFox as well, but I do not favour it.)
    WP Version: 2.7.1.

  2. axellediagram
    Member
    Posted 5 years ago #

    No one else has ever had this problem before ...? :(

  3. t31os
    Member
    Posted 5 years ago #

    This is not advice to use another browser... but does it function any differently in another browser? If it does, then the issue is not with WP... whether you like firefox is beside the point if switching browser resolves the problem.

    I don't have this issue with either Firefox 3 or IE7 or IE8. I can test from IE5.5 and IE6 to, but i think it's safe to assume it works for me at this point.

  4. axellediagram
    Member
    Posted 5 years ago #

    That's strange it doesn't happen for you as well ... It actually doesn't happen in the latest version of FF for me, either. It's strange that it only happens in IE8.

    I wonder if it's a problem that could be fixed with a registry hack ... Ahhh, the joy. :(

  5. colinbogart
    Member
    Posted 5 years ago #

    I'm having the same problem and I'm also using Vista and IE8. I previously found a set of messages about changing the timing of the autosaves, but I can't find anything in settings that will allow me to do this. I do all my editing online using a browser. I'm really a novice at this and the autosave function is making it difficult for me to finish a page.

  6. Mark / t31os
    Moderator
    Posted 5 years ago #

    wp-includes/js/autosave.js

    I think the interval is toward the top of the file...

    You can of course block this javascript in your browser (untested), but that would in theory stop the auto-saves..

  7. ponyboy
    Member
    Posted 4 years ago #

    this is happening to me to, is there a plug in that will turn off auto save once and for all?
    how do you turn this off?
    royb at roybcorp.com

  8. HCSdesigns
    Member
    Posted 4 years ago #

    I have become very frustrated with this problem too. I have a website that my client updates thierself and they are so frustrated they may not continue to use my services. I will try firefox browser today.

    Thank you for your posts.

  9. HCSdesigns
    Member
    Posted 4 years ago #

    New problem, what is the deal here - !

    When I use foxfire the visual editor does not work!

    Enters, do not creat a space beween lines or paragraphs.

    emails do not become a hyperlink....

    I use the visual editor for the simple stuff because I do not memorize all the coding - it also decreases the number of mistakes I make.

    My client will need to be able to use the visual editor as well.

    The page is more stable though, it just doen't do much. What to do???

    any input would be helpful.

  10. Mark / t31os
    Moderator
    Posted 4 years ago #

    Well i've been using Firefox since i joined the WordPress community, and it's yet to cause any problems..

    You don't need to memorize code, an understanding of code is enough to use the HTML editor.. i'd have thought you'd have some basic understanding of code already considering you sell website customization as a service...

    If you have lots of extensions or even just a few installed in firefox it's possible they could be part of the problem you mentioned.... Easy way to test this without any need to disable or remove them is to create a secondary profile in firefox (it will load up without your extensions), once you've tested, switch back to the other profile, no disabling or removing required at all.

    Of course you could just test from another browser to confirm if the problem is specific to Firefox..

    I've also pointed at 2 ways to cope with the auto-save problem if that's an issue for you.

    1. Block the script.
    2. Change the auto-save interval in the file.

  11. HCSdesigns
    Member
    Posted 4 years ago #

    Thank you, did not mean to sound like a rant. I was just frustrated at the time. What is odd though I have a new website with the new version of wordpress : http://www.lrpta.net and it works great with the foxfire browser.

    The site I had problems with - I did a manual install of the new wordpress and it still shows as an "incompete" install. Not sure where to start problem solving with this... some things on the editing piece work and some don't. http://www.rogersvillemo.net

    Thank you for your input, I often find great answers here. I understand code quite extensively but am reasonably new at wordpress. PHP and content managed type websites are a whole new can of worms for me and I'm still learning how it all work...

  12. Mark / t31os
    Moderator
    Posted 4 years ago #

    Well whats different between the two?..

    Take a copy of the problem site and install it locally, WAMP, XAMP or whatever your choosing, run some tests on it...

    Tried disabling any plugins you may have installed? Switch themes, anything is worth a shot, you'll not be losing anything because it's just a copy, so you can just reinstall it again if anything gets bodged up..

    I don't know how i ever got by without a local testing installation before, it's a must for any developer...

  13. n1spirit
    Member
    Posted 4 years ago #

    I agree; it is an annoying problem and I first began experiencing it when I upgraded to 2.8.0 (or thereabouts). Upon installation of the immediate update folling that installation it seems to go away for a short while but I've since updated again and the problem is back. I use MSIE 8 on a Vista OS. Have basically begun doing all of my coding in Notepad to avoid the annoyance of this problem and just do a cut and paste once my changes are thought to be complete.

    But 2.8.4 is now out (and appears to include a fix for a rather unsettling security oversight) so perhaps the problem will again go away today. I'm not holding my breath.

    (Don't misunderstand... I'm thankful to the programmers for providing us with this software for blogging. It's just a little annoying when we have to expend unscheduled time to fix an oversight --- or worse yet, have to live with it until a fix is provided.)

  14. shawnkltucker
    Member
    Posted 4 years ago #

    Here's a clever way to disable it.

    vinatips.com/disable-wordpress-autosave-and-revisions for a clever way to disable autosave and/or revisions.

    My problem is that autosave is still being pushed through in the Ajax calls to load-script.php, which makes an ugly page error icon appear in IE when adding a new page or post. The error shows up pretty well if you use the firebug console.

    Anyone know what file I can remove that from?

  15. LadySheila
    Member
    Posted 4 years ago #

    I'm a tellin' ya! Boy, it is a great item to have if you really need that kind of care, but if you are any kind of fast on that keyboard, it is gruesomely painful to have to be slowed down by 80% or more of what you could be doing. It back-spaces so slow, that I, well, am having a hard time not passing out from panic over it. My slow-typer friend doesn't notice it, however. Maybe, as our words are of course, so important, we really need the policing, as we all know, haste can really make waste, but I'll take the Ferrari, please! I'm downloading the plug-ins, and thank you for that great info, shawnkltucker!! By the way, I use Firefox, I8, and Chrome. It's WP in my opinion, a great safety feature, though, now, I want to be remembered for saying that.

  16. GregK
    Member
    Posted 4 years ago #

    Can someone give me a little javascript assistance on this?

    I like the autosave feature, but I'd like to change the interval, which I believe you can do in autosave.js. But I don't know javascript well enough to mess with this file.

    I'm assuming this is the line I want.

    autosavePeriodical=b.schedule({time:autosaveL10n.autosaveInterval*1000,func:function(){autosave()},repeat:true,protect:true});

    And I'm assuming I want to change "*1000" to some other value, like "*2000".

    Is that right?

    Thanks,

    Greg

  17. Mark / t31os
    Moderator
    Posted 4 years ago #

    Yep, that's right..

  18. GregK
    Member
    Posted 4 years ago #

    Thanks much!

  19. anitaharris
    Member
    Posted 4 years ago #

    I had the jumping cursor too, it was driving me crazy... every time i entered a space, or pasted or navigated out of the edit area the text was displayed from the top but the cursor remained in the correct location - i am in IE8. So i set my site to 'compatibility view' from IE8 tools menu option and that resolved the problem for me...

  20. MarjoriePaperTigers
    Member
    Posted 4 years ago #

    I thought when I read Anita's simple adjustment that hooray, I'd found the solution, but alas no... This is driving me absolutely bonkers - but there are four of us writing for our blog and somebody else deals with all the Plugins etc... Noone else has mentioned this - why would it be affecting me but not the others? And interesting that it's not happening here, in what is effectively a very similar text box...

Topic Closed

This topic has been closed to new replies.

About this Topic