WordPress.org

Ready to get started?Download WordPress

Forums

Testimonials by Aihrus
[resolved] Animation not disabling? (16 posts)

  1. bws-online
    Member
    Posted 10 months ago #

    I've disabled the animations between testimonials (via the Widget Settings tab, and via the checkbox on the widget itself) but they're still animating. Help? Thanks.

    http://wordpress.org/plugins/testimonials-widget/

  2. bws-online
    Member
    Posted 10 months ago #

    Also, it seems the time in between testimonials when the content animates isn't being accurately used (also from that Widget Settings tab).

  3. bws-online
    Member
    Posted 10 months ago #

    In addition to knowing how to disable the animations, I'd like to know how to adjust the fade in/fade out (other than modifying the code in testimonials-widget.php) -- is there a setting for this?

  4. Michael Cannon
    Member
    Plugin Author

    Posted 10 months ago #

    The animation is the smoothing of height adjustments.

    Also, once you create a testimonials widget, you need to edit the widget options directly. The WP Admin > Testimonials > Settings panel no longer affect current widgets.

  5. bws-online
    Member
    Posted 10 months ago #

    Ah, okay, so it doesn't affect the fade.

    Is there any way to adjust the fade in/fade out speed other than modifying the .php file?

    Thanks Michael!

  6. Michael Cannon
    Member
    Plugin Author

    Posted 10 months ago #

    Please see https://aihrus.zendesk.com/entries/25672673-How-do-I-override-the-JavaScript-fadeIn-.

    Now that I've been asked about speed and animations a few times, I'm adding this to the TODO to look into some options.

    What options do you suggest?

  7. bws-online
    Member
    Posted 10 months ago #

    At a minimum allow for modification of the speed of the fade in and fade out (separate fields).

    Variations could include different types of animations, I suppose (wipes, fades, etc.).

    You could have a switch to turn the animation on and off (which could be addressed by adjusting the speed, but a checkbox to turn it on/off (disabling the speed if animation turned off) would make that easier).

  8. Michael Cannon
    Member
    Plugin Author

    Posted 10 months ago #

    Thank you for the tips. They're in the TODO now.

    If you don't want rotations, just set the limit to 1.

  9. Pankaj Bhandarkar
    Member
    Posted 10 months ago #

    Hi there,
    Is there any solution to auto rotate the testimonial on page with short code.

  10. Michael Cannon
    Member
    Plugin Author

    Posted 10 months ago #

    @Pankaj Bhandarkar, please open a new support ticket. This one is already resolved.

  11. Michael Cannon
    Member
    Plugin Author

    Posted 9 months ago #

    @bws-online, I've enabled variable animation speeds. Please try out the code from https://github.com/michael-cannon/testimonials-widget.

    I'm not happy with the slide options, so I'm not doing them at this time.

  12. Pankaj Bhandarkar
    Member
    Posted 9 months ago #

    Hi there,
    I have resolved this matter on this site.
    http://flyingnurse.com/new_testimonial/

    Thanks...:)

  13. Michael Cannon
    Member
    Plugin Author

    Posted 9 months ago #

    Pankaj,

    Thank you for the JavaScript tip to use cycle. That's quite simple. I'll look into that further on my next round of changes.

    jQuery(document).ready(function() {
    jQuery('#testimonial_rotator_859').cycle( { fx : 'fade', timeout: 5000, speed: 750, pause: true, before: function() { jQuery(this).parent().animate({height: jQuery(this).height() }); } } );
    });
  14. lindaloustarr
    Member
    Posted 9 months ago #

    Ok, so most of the above is greek to me so my question is how the heck I make the time between each slide to 25 seconds, I've tried in the widget settings in both the plugin settings area as well as the widget itself, I look in the back end code & cannot figure out where to make those adjustments, as to the jquery code above where should that be placed and/or where or where to make the adjustment for 25 seconds????
    Thank you, you are greatly appreciated!
    Linda Lou

  15. Michael Cannon
    Member
    Plugin Author

    Posted 9 months ago #

    Linda,

    Normally, on resolved support entries, please start a new topic entry. You might try setting the Rotation Speed in your widget options of the testimonials widget instance to 25.

  16. Michael Cannon
    Member
    Plugin Author

    Posted 8 months ago #

    FYI, an upcoming release cleans up the JavaScript and fixes some animation quirks that might've been noticed here.

Reply

You must log in to post.

About this Plugin

About this Topic