WordPress.org

Ready to get started?Download WordPress

Forums

jQuery Smooth Scroll
[resolved] Anchor Links Not Working (6 posts)

  1. brentgalloway
    Member
    Posted 1 year ago #

    Hello,

    I downloaded, activated, and the scroll-to-top button works great! The issue I'm having is that none of my anchor links are working.

    I'm working locally on this project so unfortunately I do not have a link to share.

    With the plugin deactivated, the anchor links work just fine, but without the smooth scrolling (the page jumps to the anchored link as expected).

    With the plugin activated, the scroll-to-top shows up and works perfectly, but the anchored links do nothing at all – as if I never coded them.

    In the url bar the anchor links don't even show up. Originally they would show up as localhost/.../page#anchor – but again, with the plugin activated, if an anchored link is clicked it just shows the original link without the anchor (localhost/.../page).

    Here's an example of the code I'm using:
    Link: <a href="#link">Link</a>
    Linked to: <div id="link" name="link">

    I'm not sure if I need to code the anchor links differently for the plugin to work or what?

    I appreciate the help!

    http://wordpress.org/extend/plugins/jquery-smooth-scroll/

  2. brentgalloway
    Member
    Posted 1 year ago #

    I'm currently using Safari. I tested it in Chrome and it seems to work just fine... So I'm not sure what the issue is.

  3. Anand Kumar
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin has conflict with WP admin bar (aka toolbar). (I know its bad, will update the plugin).

    Try the feature after disabling the WordPress admin bar or when you are not logged in to wordpress. Else, it should work fine.

    Waiting for your response!

  4. Anand Kumar
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin has been updated. It should now work.

    Please create a thread if you find something wrong!!

  5. brentgalloway
    Member
    Posted 1 year ago #

    The anchor links work now with the update, they just don't smooth scroll while logged in. It's not a major concern, just as long as it functions properly for all viewers that aren't logged in.

    Thanks for the explanation and update!

  6. Anand Kumar
    Member
    Plugin Author

    Posted 1 year ago #

    You are welcome!

    I will fix that issue someday. ;)

    And thanks for your compliment.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic