WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] An Unexpected HTTP Error occurred during the API request (6 posts)

  1. SexyDawnT
    Member
    Posted 3 years ago #

    I have combed through the site and the only solution that I can find for this is to extend the timeout to 30 -- and I have done that and it didn't work. I have also uninstalled and reinstalled every plugin, switched to the default theme, etc.

    I have contacted my host and they seem to think the problem is with WordPress. I am really scratching my head here.

    I have two sites and they are BOTH spitting this error when I try to search for or update new plugins:
    An Unexpected HTTP Error occurred during the API request

    Additionally, on the dashboard, the WP development blog feed and the new plugins feed both also spit back errors or never load. They pop this error:
    WP HTTP Error: couldn't connect to host

    Both sites were fine up until a couple of days ago and then everything just blew up. I didn't change anything, so I don't know what caused it.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    The second issue is related to the server's configuration settings. It simply isn't allowing your site to access those feeds. I suspect the first problem is also related to the server config.

  3. SexyDawnT
    Member
    Posted 3 years ago #

    Which settings could be causing it? My host is pointing back at WordPress - so I need to go armed to get them to fix it.

  4. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    The server is refusing to allow direct connections to other sites or external files such as RSS feeds. Millions of people use WP and can update plugins/themes without any problem. And can have content from the WP blog delivered to their Dashboard. So it's not WordPress that's the issue - it's something that is specific to your site.

    If you have deactivated all plugins and switched to the default theme, that eliminates plugin & theme problems. So it's looking like the issue is the server.

    Both of these errors are related to the same issue - making connections to external sites. Some hosts severely restrict, or disallow, such connections on the basis of security. My guess is that your server's security configuration has been changed.

    My host is pointing back at WordPress

    Why not point them at this forum? We have more than a few major hosting providers helping out with the odd server issue. Perhaps they can look for assistance themselves?

  5. SexyDawnT
    Member
    Posted 3 years ago #

    Thanks for all the help. They finally resolved it. For some strange reason, the IP Addresses needed to access those items were both banned in the server's .htaccess files and firewalls. This was an "all-of-a-sudden" thing and they had NO IDEA how it happened. At any rate, I appreciate your assistance.

  6. bbougher
    Member
    Posted 3 years ago #

    @SexyDawnT: Are you using Network Solutions by any chance? Having same problem with a client's site that is using NS as their host. None of the solutions recommending changing timeout values have worked.

Topic Closed

This topic has been closed to new replies.

About this Topic