WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] An old favourite: .htaccess "not writable" though it is, permalinks not working (5 posts)

  1. farmer paul
    Member
    Posted 2 years ago #

    I'd like to think I'm a fairly seasoned WordPress user, so I can't believe that this is happening, but anyway. Got a standard WordPress install, 3.3.2. All WordPress files are owned and writable by Apache, including the root directory they are contained in an .htaccess (which is also chmod 777 just for the heck of it). PHP safe_mode is off (not that it should matter for this). .htaccess contains:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Despite all of these things, on the Permalink settings page, WordPress insists: "If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all." I've switched back and forth between "Default" permalink setting and other options numerous times to no avail.

    As well, despite the above contents of .htaccess, all the permalink patterns start with /?page_id=4, and none of the pages are offering the desired slug-based permalinks.

    I've already wasted an hour trying to understand what's going on here. You'd think by 3.3.2, trifling issues like this one would all be in the past!

  2. farmer paul
    Member
    Posted 2 years ago #

    There's also nothing unusual about my WP folder structure. It's installed in the HTTP root of the domain.

  3. farmer paul
    Member
    Posted 2 years ago #

    Also, a curious thing:

    Currently, every permalink rendered on the site starts with /?page_id=4/. These are the options on my permalink settings screen:

    And as you can see by visiting wellnessing.ca, every menu item's URL reflects this strange URL prefix quirk. I can't see any way to remove the ?page_id=4 portion from the permalink options.

  4. farmer paul
    Member
    Posted 2 years ago #

    Never mind... I see what my client did. She changed the General Settings Site URL to http://wellnessing.ca/?page_id=4, thinking that was the correct way to make her "About Us" page be the home page. So that's her mistake, and also mine for not checking there first.

    But man, seriously? Can't WP be a little smarter than to say that .htaccess is not writable? I know it's open source and all, but come on, this is basic if-else logic here... so friggin' misleading!!

  5. esmi
    Forum Moderator
    Posted 2 years ago #

    Under the circumstances, you're really lucky the site worked at all. It's far more common for all CSS to go AWOL under these conditions - which would have been a major clue.

    And, FWIW, I've asked (via WordPress Ideas) for some sort of alert/popup on the site urls in Settings-> General to try and stop users making these silly mistakes.

Topic Closed

This topic has been closed to new replies.

About this Topic