WordPress.org

Ready to get started?Download WordPress

Forums

Newsletter
[resolved] "Alternative custom confirmation required page" ignored (6 posts)

  1. tcolling
    Member
    Posted 1 year ago #

    Hi - I'm using WP 3.4.2 and Newsletter 3.0.9 on my site at http://www.TrustworthyCare.com

    I've created a blank page at http://www.trustworthycare.com/email-newsletter/ to use as the "Alternative custom confirmation required page" and I've entered that URL in the appropriate field for the "Alternative custom confirmation required page" in the Confirmation tab in the Subscription settings page for Newsletter.

    However, that setting appears to be ignored and the confirmation box still appears instead of the page that I created. That's not what I want, and also it is a security hole because the URL for the default confirmation box allows the user to browse the plugins files on the site (!)

    Please give it a try on my site, and let me know if you can see something that I'm doing incorrectly.

    Thanks!

    - Tim

    http://wordpress.org/extend/plugins/newsletter/

  2. tcolling
    Member
    Posted 1 year ago #

    More info: I just noticed that there is a field for "WordPress page URL for messages" on the General tab in the Subscription settings page for Newsletter.

    Is it possible to use both of these fields? Are they somehow in conflict with each other?

    - Tim

  3. tcolling
    Member
    Posted 1 year ago #

    Note also: I'm experimenting with different pages and entries in those fields, so right now if you were to try to test it with the URLs I provided above, you might not see what I originally intended you to see.

    - Tim

  4. tcolling
    Member
    Posted 1 year ago #

    Ok, for now I'm going to just use custom landing pages. It would be nice to understand how the "WordPress page URL for messages" field is supposed to work, though. If everything could be sent through one page, that would be great!

    - Tim

  5. Stefano Lissa
    Member
    Plugin Author

    Posted 1 year ago #

    See here, http://www.satollo.net/plugins/newsletter/subscription-module, on paragraph "Use the blog theme for subscription steps".

    Stefano.

  6. tcolling
    Member
    Posted 1 year ago #

    >>See here, http://www.satollo.net/plugins/newsletter/subscription-module, on paragraph "Use the blog theme for subscription steps".<<

    Thanks. I just read the instructions and tried again. I deleted the settings I had entered for the two custom landing pages for initial subscription and for acknowledging confirmation and then entered a page to use as the catchall page in the "WordPress page URL for messages" field.

    Oddly enough this time it worked, even though I was using the same page as I had before. I think that I must have entered the URL for the catchall page incorrectly or something, the first time I tried this.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic