WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] alt attribute in inserted images is empty (6 posts)

  1. Yogi T
    Member
    Posted 1 year ago #

    When inserting a single image in 3.5 RC 2 , only the caption is inserted. The alt atribute is emty (alt=""). The Attachment details fields like Title, Caption and Alt Text are filled.

  2. Whats your full WordPress version? Do you have something like 3.5-RC2-22958?

    If not, then it should be fixed in the next nightly build, see https://core.trac.wordpress.org/ticket/22640.

  3. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    I think this might be the correct behaviour. It is up to the Page/Post author to add an alt attribute to an image when it is uploaded, later edited or if it is being used as a link. An unlinked captioned image does not need an alt attribute.

  4. Yogi T
    Member
    Posted 1 year ago #

    @occean90: Its simple 3.5 RC2 Thanks, I did not see the ticket.
    @esmi: There is still no value for the alt attribute, if I insert the image without a caption or with a link.

    I will try next nighly build.

  5. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    There is still no value for the alt attribute, if I insert the image without a caption or with a link.

    Yes - as I said I think that's the expected behaviour. You have to add an alt attribute to the image before inserting it.

  6. Yogi T
    Member
    Posted 1 year ago #

    I've tryed with 3.5-RC2-22928 now and it works like expected.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.