WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Already Installed for months, WP keeps forwarding me to Install page (21 posts)

  1. daynadesastre
    Member
    Posted 5 years ago #

    I ALREADY have wordpress installed, and I have for almost half a year. When I went to update my blog, it forwarded directly to: http://daynadesastre.com/blog/wp-admin/install.php
    Anytime I click on any page in my blog in the /blog directory, it forwards me to this page.

    I already have wordpress installed... I don't want to override all my hard work!

    I just want to update my blog. Oh, and my page works fine @ http://www.daynadesastre.com, you just can't click anywhere without being forwarded.

  2. imagiscapeca
    Member
    Posted 5 years ago #

    Same problem - [url deleted so someone doesn't run the installer].
    And yes, [url removed] works fine.

    If I click Install, will it overwrite my work?

  3. Samuel B
    moderator
    Posted 5 years ago #

    Hi,
    all of your mysql tables have crashed - you need to or get host to run a repair on the database.

  4. imagiscapeca
    Member
    Posted 5 years ago #

    Using phpMyAdmin, I see my SQL tables appear properly.
    In my host's My SQL admin program, I ran a "check" of the database, and it was all okay. I ran a "repair" of the database anyway. It seems that did no good.
    Is this what you mean, samboll, by "your mysql tables have crashed"? Did I do the repair you had in mind?
    Thank you.

  5. imagiscapeca
    Member
    Posted 5 years ago #

    (My blog was using wp version 2.61.)

  6. Samuel B
    moderator
    Posted 5 years ago #

    sorry so late getting back
    i don't see the tables crashed any more - does it still redirect?

  7. imagiscapeca
    Member
    Posted 5 years ago #

    alas, yes, it still redirects from any url within the blog.

  8. whooami
    Member
    Posted 5 years ago #

    alas, yes, it still redirects from any url within the blog.

    your links above have dots in them, at least one does

    your blog is here:

    http://www.daynadesastre.com/blog

    and its working fine

  9. imagiscapeca
    Member
    Posted 5 years ago #

    No Whoami, that's the first questioner's site. Perhaps I should have started a new topic. I thought it was better protocol to add my instance of this same issue to a topic already started.
    My site is
    http://www.imagiscape.ca/blog.
    Oh - I see my url's were automatically removed when I posted my first post above.
    I emailed the owner of DaynaDesastre.com last Friday, asking how her problem got solved, since I saw that her blog was now working. I have not received a reply.

  10. whooami
    Member
    Posted 5 years ago #

    the only time that happens is when wordpress cant 'see' the wp_options table

    is that intact? is it crashed? I would doublecheck

  11. imagiscapeca
    Member
    Posted 5 years ago #

    Using phpMyAdmin, I can browse wp_options. Does that mean it is intact?

    I ran a database check again, and again everything was okay. (The tables checked (all tables) included wp_options.)

    My not-too-cheap but slow-to-respond host has now advised me to check that the server connection address is set to dbhost not localhost. Since my blog was working last week, and my host said a few days ago that they had not changed anything on their end, I don't see how this could be the issue, but it does fit with what you say about wordpress not being able to see the wp_options table. **How do I check/change the server connection address used by my wordpress installation?** I know it's not in my header templates, or htaccess, and it can't be and isn't in wp_options.

  12. Samuel B
    moderator
    Posted 5 years ago #

    check that the server connection address is set to dbhost not localhost.

    that would be in your wp-config.php file DB_HOST
    but I'm with you - if you didn't change anything and they didn't...

  13. imagiscapeca
    Member
    Posted 5 years ago #

    Thanks you two.
    No thanks to my host
    (who said, after I twice asked "Did MDS change some settings on Nov 1?",
    "No changes have been made to your account")

    Alas,
    the blog now only shows my posts up to the end of June, and my drop-down menu is now splayed out and all in one column.

    I use Lester Chan's [wp-database] plugin, and get backups sent by email, so I'll try restoring a backup.

    (My host bought my old host a few months ago.)

  14. imagiscapeca
    Member
    Posted 5 years ago #

    I didn't write that yes, changing wp-config.php's host to "dbhost" (as required by my current host) fixed the redirect-to-install.php error.

  15. imagiscapeca
    Member
    Posted 5 years ago #

    I went to wp-admin, in order to get to wp-dbManager to restore my backup, but .. quasi-catch-22 .., when I go to wp-admin, I get:
    Database Upgrade Required - Your WordPress database is out-of-date, and must be upgraded before you can continue.
    Oh well, since Ive got the backup, I guess its safe to proceed.

  16. imagiscapeca
    Member
    Posted 5 years ago #

    I did the database upgrade, which (as expected) did not restore the work I have done since June, but it did enable me to access the wp-dbmanager plugin so I could restore the most recent backup. Done. All better now.

    It's still a mystery why 4 months of work disappeared (until I restored the backup), but I'm quite sure that was due to some rare quirky action when my host bought and took over my old host.

  17. imagiscapeca
    Member
    Posted 5 years ago #

    I would click Resolved, since the original questioners' blog is now working, and so is mine, but I can't click Resolved - only the original questioner (topic creator) can do that.

  18. askoracledba
    Member
    Posted 5 years ago #

    I also faced this issue today. I was able to repair the database. But I am still seeing below error when i check tables from phpadmin tool. How do i correct it

    Problems with indexes of table wp_comments
    More than one INDEX key was created for column comment_approved

    -Amit

  19. PlatosPond
    Member
    Posted 5 years ago #

    I also have the same issue in my database
    I get the same warning
    More than one INDEX key was created for column comment_approved

    I do have two ROWS in the same COLUMN that start out with comment_approved
    (see below)

    comment_approved

    and

    comment_approved_date_gmt

    I am going to do an experiment and remove the later and see if that works. Perhaps will loose date stamp with my comments, but I can live with that.

    I really hope this does not mess everything up!
    -Fred,

  20. musthafa_zahir
    Member
    Posted 4 years ago #

    Wow! WordPress is very amazing community!

    I have got the solution now, thanks to Whooami

    Below is the fix, just follow the instructions, very simple!

    When your website redirects to wp-admin/install.php [FIX] :

    1. Login to phpMyAdmin.
    2. Select the database and click on 'Structure' tab.
    3. Right under the list of table there is a "Check All" link. Click on it to select all tables.
    4. From a "With selected:" drop-down menu right next to it, choose "Check table".

    To Repair:

    1. Login to phpMyAdmin
    2. Choose the affected database. If you only have one database, it should choose it by default so you don't need to do anything.
    3. In the main panel, you should see a list of your database tables. Check the boxes by the tables that need repair.
    4. At the bottom of the window just below the list of tables, there is a drop down menu. Choose "Repair Table"

  21. Ovidiu
    Member
    Posted 4 years ago #

    regarding: To Repair:

    what should that do? didn't change a thing for me...

    is it maybe a false warning by phpmyadmin? according to the wordpress DB schemata this is the way it should be: http://codex.wordpress.org/Database_Description#Table:_wp_comments

Topic Closed

This topic has been closed to new replies.

About this Topic