WordPress.org

Ready to get started?Download WordPress

Forums

almost there but... (7 posts)

  1. missysnow
    Member
    Posted 9 years ago #

    Hello, I thought I had WordPress installed all nice and pretty but when I log in, I get this after my i put in my username and password. tried installing twice and get the same thing. Where am I going wrong? Worpress shows up fine on my page, just can't login. Thanks !
    Warning: Cannot modify header information - headers already sent by (output started at /home/********/public_html/nascentgeekgirl/wordpress/wp-config.php:34) in /home/********/public_html/nascentgeekgirl/wordpress/wp-login.php on line 123
    Warning: Cannot modify header information - headers already sent by (output started at /home/********/public_html/nascentgeekgirl/wordpress/wp-config.php:34) in /home/********/public_html/nascentgeekgirl/wordpress/wp-login.php on line 124
    Warning: Cannot modify header information - headers already sent by (output started at /home/********/public_html/nascentgeekgirl/wordpress/wp-config.php:34) in /home/********/public_html/nascentgeekgirl/wordpress/wp-login.php on line 126
    Warning: Cannot modify header information - headers already sent by (output started at /home/********/public_html/nascentgeekgirl/wordpress/wp-config.php:34) in /home/********/public_html/nascentgeekgirl/wordpress/wp-login.php on line 127
    Warning: Cannot modify header information - headers already sent by (output started at /home/********/public_html/nascentgeekgirl/wordpress/wp-config.php:34) in /home/********/public_html/nascentgeekgirl/wordpress/wp-login.php on line 128
    Warning: Cannot modify header information - headers already sent by (output started at /home/********/public_html/nascentgeekgirl/wordpress/wp-config.php:34) in /home/********/public_html/nascentgeekgirl/wordpress/wp-login.php on line 129
    Warning: Cannot modify header information - headers already sent by (output started at /home/*********/public_html/nascentgeekgirl/wordpress/wp-config.php:34) in /home/*********/public_html/nascentgeekgirl/wordpress/wp-login.php on line 149

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Download wp-config.php
    Edit it in something like Notepad, and be sure that there is nothing at all before the <?php and nothing at all after the ?>
    That error is caused by whitespace being outside of the < or the >
    Also, <? php will cause that, it should be <?php

  3. missysnow
    Member
    Posted 9 years ago #

    This is what the config file looks like. I don't think I see what you are suggesting, but I know zero about what a file should look like so maybe you could point out where exactly i need to fix? thanks if you can help.
    --------------------
    <?php
    /** WordPress's config file **/
    /** http://wordpress.org/ **/
    // ** MySQL settings ** //
    define('DB_NAME', '********_nggblog'); // The name of the database
    define('DB_USER', '*********_*****'); // Your MySQL username
    define('DB_PASSWORD', '******'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    /* Stop editing */
    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;
    define('ABSPATH', dirname(__FILE__).'/');
    // Get everything else
    require_once(ABSPATH.'wp-settings.php');
    ?>

  4. missysnow
    Member
    Posted 9 years ago #

    oh lordy! i appreciate your help but i'm starting to feel like an idiot. where is this extra space? do you mean someplace other than the last line of the file? sorry i am not understanding. i dont see the extra space?. i looked at the config file of other installations of wordpress to try to see what you mean but they look the same and they work.

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Try this:
    In Notepad, using the arrow keys, put the cursor on the last line.
    Then press DELETE and keep it pressed for a moment or two, then type ?> and save the file.
    Do not press Enter after typing the >
    The very last line must be ?> and there must be absolutely nothing at all after that - not a space OR a carriage return.

  6. missysnow
    Member
    Posted 9 years ago #

    ahhhh! now i see what you were saying....that worked! thank you so much.

  7. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Cool :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.