WordPress.org

Ready to get started?Download WordPress

Forums

Allowed memory size issue with too many pages? (9 posts)

  1. msolution
    Member
    Posted 1 year ago #

    Hey,
    in the process of creating a plugin, which created around 36k pages,

    but when i goto wp-admin -> pages -> all pages i get the following error:

    Allowed memory size of 268435456 bytes exhausted .... wp-includes/cache.php on line 506

    memory size currently set to 256Mb,... cant go beyond that now!!!

    ( where most people just have 64 ~ 128Mb on their shared servers, )

    with pages i assume number of category or tags should not create issues.

    any help is much appreciated.

    M.

  2. mbrsolution
    Member
    Posted 1 year ago #

  3. msolution
    Member
    Posted 1 year ago #

    hey,
    thanks for your help but no didnt help.

    i installed my plugin on a clean install, and thats the only plugin there now.

    i have over 35k pages, and postmeta has only one row.

    all fields in the post table are small in size, including content,...

    even the front page is loading only half, .... no errors.

    anything else i should look into

    M.

  4. mbrsolution
    Member
    Posted 1 year ago #

    Can you disable your plugin and simple create a page? If this works then there must be some code in your plugin that is causing this issue.

  5. ricardusexa
    Member
    Posted 1 year ago #

    You will need to ask your hosting provider for what's the best solution.

  6. msolution
    Member
    Posted 1 year ago #

    i disabled the plugin, and the issue still persists,

    when i goto see all pages, the page errors out,
    when i goto add page, the side meta box page attributes errors out,

    with the same error.

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 85 bytes) in ... /wp-includes/cache.php on line 506

    i dont think this is a hosting issue,

    thanks for taking the time to help me on this.

    Regards,

  7. msolution
    Member
    Posted 1 year ago #

    tried using different themes too!

  8. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    Remove the cache limit in your wp-config.php, update it, or resolve with your web host.

  9. msolution
    Member
    Posted 1 year ago #

    i set WP_CACHE to false, and memory limit is as is 256Mb

    and this is going to be a distributable , so want this to work as is,

    any other pointers,

    would this be a limitation of wordpress?

Topic Closed

This topic has been closed to new replies.

About this Topic