WordPress.org

Ready to get started?Download WordPress

Forums

allowed memory exhausted with ecto (3 posts)

  1. drewdavidson
    Member
    Posted 6 years ago #

    Hello - I'm using ecto with wordpress and have run into this error when i try to attach a .mov that is 2.5megs... i've read through the ecto support forums and the wordpress forusm and have upped my memory_limit in my .htaccess file... and it still doesn't work... and i'm able to upload the movie directly through wordpress... below is the error message from the ecto console... thanks, drew

    Request with URL:
    http://wellenough.com/xmlrpc.php
    and data:
    <?xml version="1.0" encoding="UTF-8"?>
    <methodCall>
    <methodName>metaWeblog.newMediaObject</methodName>
    <params>
    <param>
    <value><string>1</string></value>
    </param>
    <param>
    <value><string>admin</string></value>
    </param>
    <param>
    <value><string>******</string></value>
    </param>
    <param>
    <value><struct>
    <member>
    <name>bits</name>
    <value>REMOVED</value>
    </member>
    <member>
    <name>name</name>
    <value><string>MVI_0876-7.mov</string></value>
    </member>
    <member>
    <name>type</name>
    <value><string>video/quicktime</string></value>
    </member>
    </struct></value>
    </param>
    </params>
    </methodCall>

    Response:

    <b>Fatal error</b>: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3455549 bytes) in <b>/home3/enough/wellenough-www/wp-includes/class-IXR.php</b> on line <b>221</b>

  2. theapparatus
    Member
    Posted 6 years ago #

    Right idea about bumping up the memory_limit. Probably wrong place though. Try within your server's php.ini file. You may have to get with your host to do so.

  3. drewdavidson
    Member
    Posted 6 years ago #

    thanks for the reply... and so, i contacted my host about the php.ini file, and here's the reply i received...

    I do believe the 2 ways of making PHP modifications are confusing the situation. In some server environments, it is possible to alter PHP settings by creating a php.ini file within your root directory. With the type of server environment we have, you need to alter the PHP settings within a .htaccess file. It is not possible to have both edited. A custom php.ini does not work in our server environment, and a .htaccess file does not work in an environment that uses custom php.ini to alter PHP settings. The only way to alter PHP settings on our server is via a .htaccess file, which is what we have done.

    does this make sense?

    thanks, drew

Topic Closed

This topic has been closed to new replies.

About this Topic