WordPress.org

Ready to get started?Download WordPress

Forums

Allow Comments Turning Itself Off? (14 posts)

  1. ransomsix
    Member
    Posted 5 years ago #

    I just experienced the same problem for the second time, and can't figure out what's going on. I had "Allow Comments on all posts" checked in the back end, and had the "Allow Comments" box on each post checked. Out of the blue, they all unchecked themselves. I went to my site and noticed "Comments for this posts have expired" or something like that in the comment area of each post. And this applied to all the posts, not just a few.

    So the only solution I could see is to go back and manually turn those back on in every post, and turn "Allow Comments on all posts."

    The frustrating part is this is the second time this has happened recently. Anyone else experienced this? I tried searching. Not sure if it's a plug in issue or what. But it seems to be happening out of the blue, not immediately after something has been edited.

    site is http://www.jaredsouney.com

  2. billspaced
    Member
    Posted 5 years ago #

    @ransomsix Something similar is happening to me. On new posts, I'm getting a "comments closed" value at the top of the post where the # of comments would normally be, EVEN THOUGH my settings are such that I "allow comments." However, when I make a new post, I notice that the box, "allow comments" is NOT checked.

    I don't know how to change the default behavior. Any one know how to change this?

  3. dakranii
    Member
    Posted 4 years ago #

    Under Settings > Discussions in the admin panel, do you have an expiration date for comments set? There's a check box with "Automatically close comments on articles older than X days".

  4. NatashaKhan
    Member
    Posted 4 years ago #

    I'm having the same problem with http://www.sapnamagazine.com

    I looked under Settings>Discussions and in the admin panel...there is no option for an expiration date. So that can't be it.

    I would love to know a solution!

  5. qenomesum
    Member
    Posted 4 years ago #

    today I faced with this problem. I did some changes about plug-ins and layout and after that one of my authors called me, that comments were off for his last entry. I corrected the comment settings of the post as admin but after his edit on post problem recurred.

    The changes I did today are:

    - installed EG-Series plug-in
    - uninstalled flexo-archives-widget plug-in
    - uninstalled wp-chgfontsize plug-in
    - removed Meta section from the sidebar
    - I put a link to /wp-admin to the footer

    I know last two are completely irrelevant about the problem but may be. On the other hand I checked comment options they are all on.

    anyway, any idea?

  6. kperrone
    Member
    Posted 4 years ago #

    Did this issue start after you installed any of these plugins? If you it could be one of them causing the problem. I would disable them and see if the problem consists. If it does not then enable the one by one and see what happens. This will at least help narrow down the problem causer.

  7. Tyssen
    Member
    Posted 4 years ago #

    I'm having the same problem and it's only happening on a single post on my site. The allow comments and trackback checkboxes are unchecked and I can't turn them back on. The post is one which receives a lot of trackbacks from forum threads so I thought it might have something to do with Akismet or Kramer but turning the plugins off didn't change anything.

  8. abcd789
    Member
    Posted 4 years ago #

    same problem for coments are off.. if i turn them on each post it is again getting tick off what to do plzzzz help me....

  9. qenomesum
    Member
    Posted 4 years ago #

    problem continues in the options page of eg-series plugin. i uninstalled wordpress completely. then installed the latest version. nothing changed. checkboxes getting unchecked when i click "save changes".

  10. denaflows
    Member
    Posted 4 years ago #

    Same goes for me :-(

    It happened just after I changed theme to atahualpa. All ssettings I can think of are properly set but "allow comments" turns itself unchecked right after saving the post.

    Very, very frustrating.

    All the best. Dena Flows

  11. petersejersen
    Member
    Posted 4 years ago #

    Same with me (on two different WordPress installations).

    The problem seems to be in the back-end. When you edit/write a post I no longer have an option to adjust the comment settings. I think it used to be there?

    ANY HELP WOULD BE MUCH APPRECIATED :-)

    Here is a list of the active plugins I use:

    • 404 Notifier
    • Akismet
    • Broken Link Checker
    • Datafeedr Random Ads V2
    • Duplicate Sidebar Widgets
    • Google XML Sitemaps
    • My Page Order
    • Popular Posts
    • Post-Plugin Library
    • Recent Comments
    • Recent Posts
    • Redirection
    • Search Everything
    • Search Excerpt
    • Similar Posts
    • Sociable
    • Subscribe To Comments
    • TinyMCE Advanced
    • WP Page Numbers
    • WP Super Cache
    • WP Widget Cache
  12. denaflows
    Member
    Posted 4 years ago #

    Got some news,

    I eventually got it working on my last post (http://www.denaflows.com/blog).

    Very weird behaivior though. I have to check the Allow comments box and save the post once and again untill it stays put. Then publish and pray not to find any misspelled word afterwards (I do it better in spanish than english, don't be too tough with my messages here :-) ).

    If any change is needed, I have to start all over again: check-save-check-save-check-save untill I get it done.

    Hope this helps a little, even though it's not a final solution.

    All the best. Dena Flows

  13. axokool
    Member
    Posted 4 years ago #

    im having this same problem.. in the setting page, i already set all the necessary setting so that user can comment without having to register or anything.

    but in the create post, whenever i tick the comment box, after published or update the post, the box went to un-tick itself. are there any solution to this as i would like my user to leave a comment.

    this problem really frustrating..

  14. rohit.nambiar
    Member
    Posted 4 years ago #

    Hello friends i was having this problem that automatically the allow comments and allow pings was unchecking..

    i tried many things to solve the problem..

    but in the end i found the solution which is working perfectly on my wp..

    i hope it will solve others problem too..

    what i do now is after creating a post i go to quick edit and from there i am checking on allow comments and allow pings..

    after updating its working ;)

    but if u will again go to full edit and update the post, it will close the comments so use quick edit to allow comments and pings....

    Thanks !!

    http://www.techyou.info :)

Topic Closed

This topic has been closed to new replies.

About this Topic