WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Landing Pages
[resolved] All visitors only receiving A variation (7 posts)

  1. dmcknze
    Member
    Posted 8 months ago #

    I have a landing page with 3 variations (http://themckenziefirm.com/go/estate-planning-course), but only the A variation is being served so far. I have W3 Total Cache installed.

    Also, fyi, when you hover over the variations in the "Variation Testing Stats" column and the box pops up with the "edit" and "preview" buttons, the word "variation" is misspelled on the buttons.

    Thanks,
    Dan

    http://wordpress.org/plugins/landing-pages/

  2. David Wells
    Member
    Plugin Author

    Posted 8 months ago #

    Make sure your htaccess file is writable. It controls the a/b switching.

    Can you look in the debug tab of settings and post your htaccess here?

  3. dmcknze
    Member
    Posted 8 months ago #

    Options +FollowSymlinks
    RewriteEngine on
    rewritecond %{http_host} ^themckenziefirm.com [nc]
    rewriterule ^(.*)$ http://www.themckenziefirm.com/$1 [r=301,nc]

    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  4. David Wells
    Member
    Plugin Author

    Posted 8 months ago #

    You are missing the landing page rewrites. You need the bolded text inside your rewrite rules

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{QUERY_STRING} !lp-variation-id
    RewriteRule ^go/([^/]*)? /wp-content/plugins/landing-pages/modules/module.redirect-ab-testing.php?permalink_name=$1 [QSA,L]
    RewriteRule ^landing-page=([^/]*)? /wp-content/plugins/landing-pages/modules/module.redirect-ab-testing.php?permalink_name=$1 [QSA,L]

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  5. dmcknze
    Member
    Posted 8 months ago #

    Thanks! I will give it a shot and let you know when I've confirmed it works.

  6. dmcknze
    Member
    Posted 8 months ago #

    Unfortunately, this does not appear to have solved the problem. I have had 10 more people visit over the last day, and they've all gone to the 'A' variation. To confirm, here's the current version of my .htaccess file:

    Options +FollowSymlinks
    RewriteEngine on
    rewritecond %{http_host} ^themckenziefirm.com [nc]
    rewriterule ^(.*)$ http://www.themckenziefirm.com/$1 [r=301,nc]

    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{QUERY_STRING} !lp-variation-id
    RewriteRule ^go/([^/]*)? /wp-content/plugins/landing-pages/modules/module.redirect-ab-testing.php?permalink_name=$1 [QSA,L]
    RewriteRule ^landing-page=([^/]*)? /wp-content/plugins/landing-pages/modules/module.redirect-ab-testing.php?permalink_name=$1 [QSA,L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  7. David Wells
    Member
    Plugin Author

    Posted 8 months ago #

    Sounds like a plugin/theme conflict.

    To test for a theme conflict:

    1. Activate default Twenty Ten, Eleven, Twelve, or Thirteen theme
    2. Check to see if the issue still occurs
    3. If the issue does not occur after having activated the default "Twenty" theme, your theme is causing a conflict with landing pages.

    To test for a plugin conflict:

    1. Deactivate ALL plugins
    2. Activate Landing Pages
    3. Check to see if the issue occurs

    If the issue does not occur, one (or more) of your plugins is causing a conflict with Landing Pages.

    To determine which plugin(s) is causing the conflict, follow these steps:

    1. Activate each plugin one by one
    2. Check to see if the issue occurs after each plugin is activated

Reply

You must log in to post.

About this Plugin

About this Topic