WordPress.org

Ready to get started?Download WordPress

Forums

All users except admin getting error while trying to access wp-login.php. (10 posts)

  1. askags
    Member
    Posted 7 months ago #

    Hi!

    I have a wordpress installation on my website https://advisorjoint.com/blogs. Now the issue that I am facing is that all users except admin are getting "You do not have sufficient permissions to access this page." error when they try to access their wordpress dashboard.

    One thing is that when they try to access dashboard from http://advisorjoint.com/blogs/wp-admin/ then they will get this error, however when they change the URL to their Blog_URL/wp-admin then they are able to access the wordpress dashboard. Also when they try to access someone else's blog dashboard, they get an error that they are trying to access someone else's blog. Below which it shows your sites and their sites are displayed. However in your sites the main blog URL is also there.

    I think there is some user role issue with my blog and I have tried to change the wp_user_roles in wp_option table, to the default user value, still I am facing the same issue.

    I used a plugin named "Multisite User Management" which might have caused this problem.

    Any help will be greatly appreciated.

  2. Are they added to the main site as users?

  3. askags
    Member
    Posted 7 months ago #

    Yes, they are added to main site as users.
    Although I have deleted that plugin (""Multisite User Management"), but still new users are becoming my main site's user, also getting this "You do not have sufficient permissions to access this page." error.

  4. Are they listed on domain.com/wp-admin/users.php and, if so, with what role?

  5. askags
    Member
    Posted 7 months ago #

    No, they are not listed in /wp-admin/users.php

    Actually there is a strange thing. All users are showing as assigned to main site in the site list (Network admin>Sites>All sites) at URL https://advisorjoint.com/blogs/wp-admin/network/sites.php [Screenshot http://share.advisorjoint.com/images/Screen%20Shot%202014-02-12%20at%202.16.55%20pm.png. Also in Network Admin>Users>All users, main site is shown as site of each user (URL: https://advisorjoint.com/blogs/wp-admin/network/users.php [Screenshot http://share.advisorjoint.com/images/Screen%20Shot%202014-02-12%20at%202.16.40%20pm.png).

    However when I open user list in the main site (at URL: https://advisorjoint.com/blogs/wp-admin/network/site-users.php?id=1 [Screenshot http://share.advisorjoint.com/images/Screen%20Shot%202014-02-12%20at%202.17.00%20pm.png) it shows admin as the only user, also in site user of main site (URL: https://advisorjoint.com/blogs/wp-admin/users.php [Screenshot http://share.advisorjoint.com/images/Screen%20Shot%202014-02-12%20at%202.17.13%20pm.png) shows only admin as the users (as stated above in the first line).

  6. 3.5.2 ... Yeah, there were some bugs with that in older versions. Any reason you can't upgrade to 3.8.1?

  7. askags
    Member
    Posted 7 months ago #

    Actually I am using few plugins that are currently now compatible with 3.8.1, so have to stay at 3.5.2 only.

  8. You do understand that "compatible up to 3.8" doesn't mean they won't work, right? If you're holding off on upgrading because of plugins not documenting they're functional on 3.8, you're making a mistake.

    You need to upgrade. No one is going to spend a lot of time debugging something from years ago when it may have already been resolved.

  9. askags
    Member
    Posted 6 months ago #

    Hi!

    I am still getting the same issue even after updating to WordPress 3.8

  10. What happens if you try to re-add them to the /blogs/ site?

Reply

You must log in to post.

About this Topic