WordPress.org

Ready to get started?Download WordPress

Forums

Google XML Sitemaps
All URLs in sitemap are https not http (7 posts)

  1. beerinfinity
    Member
    Posted 8 months ago #

    All the URL's in our sitemap.xml file are https rather than http - is this an issue and will it affect Google Webmaster and/or Google Bot?

    http://wordpress.org/plugins/google-sitemap-generator/

  2. Yui
    Member
    Posted 8 months ago #

    I wanted to report the same issue.

    When sitemap is auto-rebuilt and admin area is SSL
    (FORCE_SSL_ADMIN) then all urls in sitemap are https://

    manual rebuild from admin area or rebuild with GET is okey and urls are http:// just as expected.

  3. beerinfinity
    Member
    Posted 8 months ago #

    Our site has 20k+ pages so the manual rebuild does not always work - any idea if Google cares about whether the URLs are HTTP or HTTPS?

  4. Yui
    Member
    Posted 8 months ago #

    http and https are different sites for google, as i know.
    and its generally bad idea to have same pages available under https and http, i use redirect rules for public site.

    however, if you have link rel canonical specified - SE should use it and index the proper page.

  5. beerinfinity
    Member
    Posted 8 months ago #

    All my site pages have the following so in theory should be fine:

    <link rel="canonical" href="http://www.beerinfinity.com/page-static-url/" />

  6. sewid
    Member
    Posted 8 months ago #

    Same problem here. It would be greade, if Google XML Sitemaps uses the sites base url from the configuration to use as base url for the sitemaps.

  7. Herbert
    Member
    Posted 7 months ago #

    Today I found the same problem on my site. And I need to add that I am ~99% sure that this is a new issue. I tested sitemaps initially when I installed this plugin (several months ago) and also inbetween when updates happened. And I saw no problems.
    Today I saw this issue the first time, after updating WP to 3.7.1 on the weekend... not sure if it is related or if this problem started earlier.

    Situation is the same: the BACKEND is on https, but the frontend is on http. But the sitemap shows all URL's as https, including even the xls stylesheet.

    This is not good. The URL's in the sitemap MUST refer to the configured frontend base URL, which is http and not https.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags